summaryrefslogtreecommitdiffstats
path: root/src/Applet/Makefile.am
diff options
context:
space:
mode:
authorDenys Vlasenko <vda.linux@googlemail.com>2009-09-18 15:07:11 +0200
committerDenys Vlasenko <vda.linux@googlemail.com>2009-09-18 15:07:11 +0200
commit43fe926f20bd427e96a22081deace10752bb4533 (patch)
tree64a3a9950ad659ad3ff193df2916d05e31fa085c /src/Applet/Makefile.am
parent73c3f5fba688d9359dbf79f70b8759aee2857e41 (diff)
downloadabrt-43fe926f20bd427e96a22081deace10752bb4533.tar.gz
abrt-43fe926f20bd427e96a22081deace10752bb4533.tar.xz
abrt-43fe926f20bd427e96a22081deace10752bb4533.zip
abrt-applet: remove dbus-c++ glue. -50k of code
text data bss dec hex filename 70529 2144 1528 74201 121d9 abrt.t0/UNPACKED/usr/bin/abrt-applet 22116 1688 376 24180 5e74 abrt.t1/UNPACKED/usr/bin/abrt-applet Also, we do not use dbus-c++ anymore, which is 200k of code Signed-off-by: Denys Vlasenko <vda.linux@googlemail.com>
Diffstat (limited to 'src/Applet/Makefile.am')
-rw-r--r--src/Applet/Makefile.am9
1 files changed, 4 insertions, 5 deletions
diff --git a/src/Applet/Makefile.am b/src/Applet/Makefile.am
index 67c17766..d0980440 100644
--- a/src/Applet/Makefile.am
+++ b/src/Applet/Makefile.am
@@ -2,8 +2,7 @@ bin_PROGRAMS = abrt-applet
abrt_applet_SOURCES = \
Applet.cpp \
- CCApplet.h CCApplet.cpp \
- DBusClientProxy.h DBusClientProxy.cpp
+ CCApplet.h CCApplet.cpp
abrt_applet_CPPFLAGS = \
-Wall -Werror \
-I$(srcdir)/../../inc \
@@ -17,15 +16,15 @@ abrt_applet_CPPFLAGS = \
-DPLUGINS_LIB_DIR=\"$(PLUGINS_LIB_DIR)\" \
-DPLUGINS_CONF_DIR=\"$(PLUGINS_CONF_DIR)\" \
$(GTK_CFLAGS) \
- $(DBUSCPP_CFLAGS) \
+ $(DBUS_CFLAGS) \
-D_GNU_SOURCE
# $(LIBNOTIFY_CFLAGS)
-# $(DBUS_CFLAGS)
# $(DBUS_GLIB_CFLAGS)
abrt_applet_LDADD = \
+ ../../lib/Utils/libABRTUtils.la \
-lglib-2.0 \
-lgthread-2.0 \
- $(DBUSCPP_LIBS) \
+ $(DBUS_LIBS) \
$(LIBNOTIFY_LIBS)
# ../../lib/Utils/libABRTUtils.la
# $(DL_LIBS)