summaryrefslogtreecommitdiffstats
path: root/lib/plugins/Makefile.am
diff options
context:
space:
mode:
authorDenys Vlasenko <dvlasenk@redhat.com>2010-08-27 14:05:57 +0200
committerDenys Vlasenko <dvlasenk@redhat.com>2010-08-27 14:05:57 +0200
commit0e8b934e6007545b1a0af0fde11bfca36b72cd6a (patch)
treebb739538eb0edaccae3fc276975ddc8c0948414f /lib/plugins/Makefile.am
parentf76b61fdd8e4423e4e5604c91578e46bf65c3242 (diff)
downloadabrt-0e8b934e6007545b1a0af0fde11bfca36b72cd6a.tar.gz
abrt-0e8b934e6007545b1a0af0fde11bfca36b72cd6a.tar.xz
abrt-0e8b934e6007545b1a0af0fde11bfca36b72cd6a.zip
CCpp.cpp: add -Wall -Werror, fix two discovered bugs
Signed-off-by: Denys Vlasenko <dvlasenk@redhat.com>
Diffstat (limited to 'lib/plugins/Makefile.am')
-rw-r--r--lib/plugins/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/lib/plugins/Makefile.am b/lib/plugins/Makefile.am
index 147a778e..a896e144 100644
--- a/lib/plugins/Makefile.am
+++ b/lib/plugins/Makefile.am
@@ -67,7 +67,8 @@ UTILS_PATH=$(srcdir)/../utils
libCCpp_la_SOURCES = CCpp.cpp CCpp.h CCpp_sha1.cpp CCpp_sha1.h
libCCpp_la_LDFLAGS = -avoid-version
#libCCpp_la_LIBADD =
-libCCpp_la_CPPFLAGS = -I$(INC_PATH) -I$(UTILS_PATH) \
+libCCpp_la_CPPFLAGS = -Wall -Werror \
+ -I$(INC_PATH) -I$(UTILS_PATH) \
-DCCPP_HOOK_PATH=\"${libexecdir}/abrt-hook-ccpp\" \
-DDEBUG_DUMPS_DIR=\"$(DEBUG_DUMPS_DIR)\" \
-DLOCALSTATEDIR='"$(localstatedir)"'