summaryrefslogtreecommitdiffstats
path: root/lib/Utils/Makefile.am
diff options
context:
space:
mode:
authorDenys Vlasenko <vda.linux@googlemail.com>2009-09-15 12:43:01 +0200
committerDenys Vlasenko <vda.linux@googlemail.com>2009-09-15 12:43:01 +0200
commit0f91e9a06aa0f68a2cbe3c9fc4a858c0a5e6744a (patch)
tree13f92f2fc02d346d8474ef03fd0596e3e0447eda /lib/Utils/Makefile.am
parent5f4a56f97f36e9cb844fcf3e4399cea67000a6bb (diff)
downloadabrt-0f91e9a06aa0f68a2cbe3c9fc4a858c0a5e6744a.tar.gz
abrt-0f91e9a06aa0f68a2cbe3c9fc4a858c0a5e6744a.tar.xz
abrt-0f91e9a06aa0f68a2cbe3c9fc4a858c0a5e6744a.zip
unify CommLayer, MiddleWare and Utils into Utils
Signed-off-by: Denys Vlasenko <vda.linux@googlemail.com>
Diffstat (limited to 'lib/Utils/Makefile.am')
-rw-r--r--lib/Utils/Makefile.am47
1 files changed, 35 insertions, 12 deletions
diff --git a/lib/Utils/Makefile.am b/lib/Utils/Makefile.am
index cb5b3377..b662ae9a 100644
--- a/lib/Utils/Makefile.am
+++ b/lib/Utils/Makefile.am
@@ -1,17 +1,40 @@
lib_LTLIBRARIES = libABRTUtils.la
-libABRTUtils_la_SOURCES = \
- DebugDump.cpp DebugDump.h \
- CrashTypesSocket.cpp \
- xfuncs.cpp \
- read_write.cpp \
- logging.cpp \
- copyfd.cpp \
- Polkit.cpp \
- Polkit.h
-libABRTUtils_la_LDFLAGS = -version-info 0:1:0
-libABRTUtils_la_LIBADD = -lmagic $(POLKIT_LIBS)
-libABRTUtils_la_CPPFLAGS = -I$(srcdir)/../../inc -I$(srcdir)/../../lib/CommLayer $(POLKIT_CFLAGS)
+libABRTUtils_la_SOURCES = \
+ xfuncs.cpp \
+ read_write.cpp \
+ logging.cpp \
+ copyfd.cpp \
+ CrashTypesSocket.cpp \
+ DebugDump.h DebugDump.cpp \
+ DBusClientProxy.h DBusClientProxy.cpp \
+ CommLayerInner.h CommLayerInner.cpp \
+ Plugin.h Plugin.cpp \
+ Polkit.h Polkit.cpp \
+ Action.h Database.h Reporter.h Analyzer.h \
+ Observer.h \
+ DBusCommon.h
+libABRTUtils_la_LDFLAGS = \
+ -version-info 0:1:0 \
+ $(DL_LIBS) \
+ $(RPM_LIBS) \
+ $(DBUSCPP_LIBS)
+libABRTUtils_la_LIBADD = \
+ -lmagic \
+ $(POLKIT_LIBS)
+libABRTUtils_la_CPPFLAGS = \
+ -Wall -Werror \
+ -I$(srcdir)/../../inc \
+ -DDEBUG_DUMPS_DIR=\"$(DEBUG_DUMPS_DIR)\" \
+ -DPLUGINS_LIB_DIR=\"$(PLUGINS_LIB_DIR)\" \
+ -DPLUGINS_CONF_DIR=\"$(PLUGINS_CONF_DIR)\" \
+ -DCONF_DIR=\"$(CONF_DIR)\" \
+ -DVAR_RUN=\"$(VAR_RUN)\" \
+ $(RPM_CFLAGS) \
+ $(GLIB_CFLAGS) \
+ $(DBUSCPP_CFLAGS) \
+ $(POLKIT_CFLAGS) \
+ -D_GNU_SOURCE
install-data-local:
$(mkdir_p) '$(DESTDIR)/$(DEBUG_DUMPS_DIR)'