summaryrefslogtreecommitdiffstats
path: root/abrt.spec
diff options
context:
space:
mode:
authorDenys Vlasenko <dvlasenk@redhat.com>2010-09-20 14:32:34 +0200
committerDenys Vlasenko <dvlasenk@redhat.com>2010-09-20 14:32:34 +0200
commitd5850083f43507efe38becf589e99fe467239e4c (patch)
treee82fbf6864c07928445fabb3201670616f5ea588 /abrt.spec
parent9cfd64c47925338185d8d4b3252c9d53dc8d7afb (diff)
downloadabrt-d5850083f43507efe38becf589e99fe467239e4c.tar.gz
abrt-d5850083f43507efe38becf589e99fe467239e4c.tar.xz
abrt-d5850083f43507efe38becf589e99fe467239e4c.zip
This patch splits off CCpp's backtrace generation into a separate tool:
$ abrt-action-generate-backtrace -z abrt-action-generate-backtrace: invalid option -- 'z' Usage: abrt-action-generate-backtrace -d DIR [-i DIR1:DIR2] [-t SECONDS] [-vs] Generate backtrace, its quality rating, hash, and crashed function Options: -d DIR Crash dump directory -i DIR1:DIR2 Additional debuginfo directories -t SECONDS Kill gdb if it runs for more than SECONDS -v Verbose -s Log to syslog This also allows for debugging and regression testing of abrt-action-generate-backtrace separately - it can be simply run from command-line. Also it provides a better fault isolation - crash in abrt-action-generate-backtrace does not take down abrtd. The code is based on CCpp.cpp. CCpp analyzer is made to spawn a child to do the backtrace generation. Signed-off-by: Denys Vlasenko <dvlasenk@redhat.com>
Diffstat (limited to 'abrt.spec')
-rw-r--r--abrt.spec1
1 files changed, 1 insertions, 0 deletions
diff --git a/abrt.spec b/abrt.spec
index c8b96f73..a26063a0 100644
--- a/abrt.spec
+++ b/abrt.spec
@@ -349,6 +349,7 @@ fi
%endif
%{_sbindir}/abrtd
%{_sbindir}/abrt-server
+%{_sbindir}/abrt-action-generate-backtrace
%{_bindir}/%{name}-debuginfo-install
%{_bindir}/%{name}-handle-upload
%{_bindir}/%{name}-backtrace