summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorNikola Pajkovsky <npajkovs@redhat.com>2011-04-27 14:31:39 +0200
committerNikola Pajkovsky <npajkovs@redhat.com>2011-04-27 14:31:39 +0200
commite10c31ccbf72f3408ed2ba6488989860b7d9a2a5 (patch)
tree3e5fad04daafe17826129a1149bb448335719148 /Makefile.am
parentd256c71533829299088f48fc0aa8dbfcffcd5961 (diff)
downloadabrt-e10c31ccbf72f3408ed2ba6488989860b7d9a2a5.tar.gz
abrt-e10c31ccbf72f3408ed2ba6488989860b7d9a2a5.tar.xz
abrt-e10c31ccbf72f3408ed2ba6488989860b7d9a2a5.zip
generate abrt version from git
Signed-off-by: Nikola Pajkovsky <npajkovs@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am18
1 files changed, 8 insertions, 10 deletions
diff --git a/Makefile.am b/Makefile.am
index 6f38997f..7201f608 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -4,7 +4,8 @@ SUBDIRS = src po icons tests doc
DISTCHECK_CONFIGURE_FLAGS = \
--with-systemdsystemunitdir=$$dc_install_base/$(systemdsystemunitdir)
-EXTRA_DIST = doc/coding-style abrt.spec abrt.pc.in doc/abrt-plugin/ doc/howto-write-reporter
+EXTRA_DIST = doc/coding-style abrt.spec.in abrt.pc.in doc/abrt-plugin/ doc/howto-write-reporter \
+ gen-version
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = abrt.pc
@@ -16,18 +17,15 @@ RPM_DIRS = --define "_sourcedir `pwd`" \
--define "_srcrpmdir `pwd`"
rpm: dist
+ ./gen-version
rpmbuild $(RPM_DIRS) -ba abrt.spec
srpm: dist
+ ./gen-version
rpmbuild $(RPM_DIRS) -bs abrt.spec
-test-rpm: dist
- rpmbuild --define "_buildid `date +%G%m%d%H%M%S`" \
- $(RPM_DIRS) -ba abrt.spec
-
-test-srpm: dist
- rpmbuild --define "_buildid `date +%G%m%d%H%M%S`" \
- $(RPM_DIRS) -bs abrt.spec
-
+# value for overriding from command line
+# e.g: make scratch-build DIST=f15
+DIST=rawhide
scratch-build: srpm
- koji build --scratch dist-f12 $(PACKAGE)-$(VERSION)-1.fc12.src.rpm
+ koji build --scratch dist-$(DIST) `make srpm | grep Wrote | cut -d' ' -f2`