summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAdam Tkac <atkac@redhat.com>2009-05-29 11:29:56 +0200
committerMartin Nagy <mnagy@redhat.com>2009-06-02 12:00:49 +0200
commiteec259cac988c901fd7bb664dc9b84a0df3ccbf1 (patch)
treea0dcca8065f035d61223cf9537fa4ebb3e6e988a /configure.ac
parent526c492627f0e14d04750569dcf0a2ff726d4b73 (diff)
downloadldap_driver-eec259cac988c901fd7bb664dc9b84a0df3ccbf1.tar.gz
ldap_driver-eec259cac988c901fd7bb664dc9b84a0df3ccbf1.tar.xz
ldap_driver-eec259cac988c901fd7bb664dc9b84a0df3ccbf1.zip
Define docdir if autoconf (older versions, 2.59, for example) doesn't define it.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6f1f521..b91444f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -41,5 +41,9 @@ int main(void) {
[AC_MSG_ERROR([Cross compiling is not supported.])]
)
+# Older autoconf (2.59, for example) doesn't define docdir
+[[ -n "$docdir" ]] && docdir='${datarootdir}/doc/${PACKAGE_TARNAME}'
+AC_SUBST([docdir])
+
AC_CONFIG_FILES([Makefile doc/Makefile src/Makefile])
AC_OUTPUT