summaryrefslogtreecommitdiffstats
path: root/daemons/configure.ac
diff options
context:
space:
mode:
authorNathaniel McCallum <npmccallum@redhat.com>2013-04-16 16:00:09 -0400
committerMartin Kosek <mkosek@redhat.com>2013-05-17 09:30:51 +0200
commit5b58348cd316dd817672cb81358ed557c28e09d3 (patch)
tree0c59e7562938554fc3c217a42d0698e08dde3c3a /daemons/configure.ac
parent1e1bab4edc0ce4b70a370deac8109092b53b97a2 (diff)
downloadfreeipa-5b58348cd316dd817672cb81358ed557c28e09d3.tar.gz
freeipa-5b58348cd316dd817672cb81358ed557c28e09d3.tar.xz
freeipa-5b58348cd316dd817672cb81358ed557c28e09d3.zip
Add OTP support to ipa-pwd-extop
During LDAP bind, this now plugin determines if a user is enabled for OTP authentication. If so, then the OTP is validated in addition to the password. This allows 2FA during user binds. https://fedorahosted.org/freeipa/ticket/3367 http://freeipa.org/page/V3/OTP
Diffstat (limited to 'daemons/configure.ac')
-rw-r--r--daemons/configure.ac39
1 files changed, 6 insertions, 33 deletions
diff --git a/daemons/configure.ac b/daemons/configure.ac
index 371c28d0..21d4e7a7 100644
--- a/daemons/configure.ac
+++ b/daemons/configure.ac
@@ -22,37 +22,10 @@ AM_CONDITIONAL([HAVE_GCC], [test "$ac_cv_prog_gcc" = yes])
AC_SUBST(VERSION)
dnl ---------------------------------------------------------------------------
-dnl - Check for NSPR
+dnl - Check for NSPR/NSS
dnl ---------------------------------------------------------------------------
-AC_CHECK_HEADER(nspr4/nspr.h)
-AC_CHECK_HEADER(nspr/nspr.h)
-if test "x$ac_cv_header_nspr4_nspr_h" = "xno" && test "x$ac_cv_header_nspr_nspr_h" = "xno" ; then
- AC_MSG_ERROR([Required NSPR header not available (nspr-devel)])
-fi
-if test "x$ac_cv_header_nspr4_nspr_h" = "xyes" ; then
- NSPR4="-I/usr/include/nspr4"
-fi
-if test "x$ac_cv_header_nspr_nspr_h" = "xyes" ; then
- NSPR4="-I/usr/include/nspr"
-fi
-
-dnl ---------------------------------------------------------------------------
-dnl - Check for NSS
-dnl ---------------------------------------------------------------------------
-SAVE_CPPFLAGS=$CPPFLAGS
-CPPFLAGS=$NSPR4
-AC_CHECK_HEADER(nss3/nss.h)
-AC_CHECK_HEADER(nss/nss.h)
-CPPFLAGS=$SAVE_CPPFLAGS
-if test "x$ac_cv_header_nss3_nss_h" = "xno" && test "x$ac_cv_header_nss_nss_h" = "xno" ; then
- AC_MSG_ERROR([Required NSS header not available (nss-devel)])
-fi
-if test "x$ac_cv_header_nss3_nss_h" = "xyes" ; then
- NSS3="-I/usr/include/nss3"
-fi
-if test "x$ac_cv_header_nss_nss_h" = "xyes" ; then
- NSS3="-I/usr/include/nss"
-fi
+PKG_CHECK_MODULES([NSPR], [nspr], [], [AC_MSG_ERROR([libnspr not found])])
+PKG_CHECK_MODULES([NSS], [nss], [], [AC_MSG_ERROR([libnss not found])])
dnl ---------------------------------------------------------------------------
dnl - Check for DS slapi plugin
@@ -60,7 +33,7 @@ dnl ---------------------------------------------------------------------------
# Need to hack CPPFLAGS to be able to correctly detetct slapi-plugin.h
SAVE_CPPFLAGS=$CPPFLAGS
-CPPFLAGS=$NSPR4
+CPPFLAGS=$NSPR_CFLAGS
AC_CHECK_HEADER(dirsrv/slapi-plugin.h)
if test "x$ac_cv_header_dirsrv_slapi-plugin_h" = "xno" ; then
AC_MSG_ERROR([Required 389-ds header not available (389-ds-base-devel)])
@@ -96,7 +69,7 @@ dnl - Check for Mozilla LDAP and OpenLDAP SDK
dnl ---------------------------------------------------------------------------
SAVE_CPPFLAGS=$CPPFLAGS
-CPPFLAGS="$NSPR4 $NSS3"
+CPPFLAGS="$NSPR_CFLAGS $NSS_CFLAGS"
AC_CHECK_HEADER(svrcore.h)
AC_CHECK_HEADER(svrcore/svrcore.h)
if test "x$ac_cv_header_svrcore_h" = "xno" && test "x$ac_cv_header_svrcore_svrcore_h" = "xno" ; then
@@ -144,7 +117,7 @@ AC_ARG_WITH([openldap],
[compile plugins with openldap instead of mozldap])],
[], [])
-LDAP_CFLAGS="${OPENLDAP_CFLAGS} $NSPR4 $NSS3 -DUSE_OPENLDAP"
+LDAP_CFLAGS="${OPENLDAP_CFLAGS} $NSPR_CFLAGS $NSS_CFLAGS -DUSE_OPENLDAP"
LDAP_LIBS="${OPENLDAP_LIBS}"
AC_DEFINE_UNQUOTED(WITH_OPENLDAP, 1, [Use OpenLDAP libraries])