summaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index eb7ad94f..ea6860d5 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -63,10 +63,16 @@ TESTS += \
tcp-msgreduc-vg.sh
endif
+
if ENABLE_MYSQL_TESTS
TESTS += \
mysql-basic.sh \
mysql-asyn.sh
+if ENABLE_OMLIBDBI
+TESTS += \
+ libdbi-basic.sh \
+ libdbi-asyn.sh
+endif
if HAVE_VALGRIND
TESTS += \
mysql-basic-vg.sh \
@@ -74,6 +80,7 @@ TESTS += \
endif
endif
+
if ENABLE_IMPTCP
TESTS += \
manyptcp.sh \
@@ -367,6 +374,10 @@ EXTRA_DIST= 1.rstest 2.rstest 3.rstest err1.rstest \
resultdata/imuxsock_ccmiddle.log \
testsuites/mysql-truncate.sql \
testsuites/mysql-select-msg.sql \
+ libdbi-basic.sh \
+ testsuites/libdbi-basic.conf \
+ libdbi-asyn.sh \
+ testsuites/libdbi-asyn.conf \
mysql-basic.sh \
mysql-basic-vg.sh \
testsuites/mysql-basic.conf \