summaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 3e07e1c6..7527b27f 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -13,7 +13,6 @@ TESTS = $(TESTRUNS) cfg.sh \
rulesetmultiqueue.sh \
manytcp.sh \
rsf_getenv.sh \
- tcp-msgreduc-vg.sh \
imtcp_conndrop.sh \
imtcp_addtlframedelim.sh \
sndrcv.sh \
@@ -49,10 +48,15 @@ TESTS = $(TESTRUNS) cfg.sh \
imuxsock_traillf_root.sh \
imuxsock_ccmiddle_root.sh \
discard-rptdmsg.sh \
- discard-rptdmsg-vg.sh \
discard.sh \
queue-persist.sh
+if HAVE_VALGRIND
+TESTS += \
+ discard-rptdmsg-vg.sh \
+ tcp-msgreduc-vg.sh
+endif
+
if ENABLE_IMPTCP
TESTS += \
manyptcp.sh \