summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 65cfae82..c7050772 100644
--- a/configure.ac
+++ b/configure.ac
@@ -27,6 +27,8 @@ case "${host}" in
;;
esac
+AC_DEFINE_UNQUOTED([HOSTENV], "$host", [the host environment, can be queried via a system variable])
+
# Checks for libraries.
save_LIBS=$LIBS
LIBS=
@@ -232,6 +234,7 @@ AC_ARG_ENABLE(inet,
esac],
[enable_inet="yes"]
)
+AM_CONDITIONAL(ENABLE_INET, test x$enable_inet = xyes)
if test "$enable_inet" = "yes"; then
AC_DEFINE(SYSLOG_INET, 1, [network support is integrated.])
fi