summaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2011-06-10 22:43:00 +0200
committerRainer Gerhards <rgerhards@adiscon.com>2011-06-10 22:43:00 +0200
commite1d21ca141706f730067e20958bbdd973672e019 (patch)
tree62fe65f8e5630ea8487837d701193196bec97282 /tests/Makefile.am
parentcca47caf92eaea4ae57cc9b016d9b458157447ce (diff)
downloadrsyslog-e1d21ca141706f730067e20958bbdd973672e019.tar.gz
rsyslog-e1d21ca141706f730067e20958bbdd973672e019.tar.xz
rsyslog-e1d21ca141706f730067e20958bbdd973672e019.zip
bugfix: memory leak in imtcp & subsystems under some circumstances
This leak is tied to error conditions which lead to incorrect cleanup of some data structures.
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 3be4f296..ed25c388 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -108,6 +108,7 @@ TESTS += \
if HAVE_VALGRIND
TESTS += imtcp-tls-basic-vg.sh \
imtcp_conndrop_tls-vg.sh
+ manytcp-too-few-tls-vg.sh
endif
endif
@@ -274,6 +275,8 @@ EXTRA_DIST= 1.rstest 2.rstest 3.rstest err1.rstest \
testsuites/udp-msgreduc-orgmsg-vg.conf \
udp-msgreduc-vg.sh \
testsuites/udp-msgreduc-vg.conf \
+ manytcp-too-few-tls.sh \
+ testsuites/manytcp-too-few-tls.conf \
manytcp.sh \
testsuites/manytcp.conf \
manyptcp.sh \