summaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2009-03-31 20:35:15 +0200
committerRainer Gerhards <rgerhards@adiscon.com>2009-03-31 20:35:15 +0200
commitd27edc7587dba7b850759d151d90cdad1cb34a35 (patch)
treea8c56137d4509340df975f9bc29238f3c5cdec9a /tests/Makefile.am
parent3b9fd5330a6599c00e9c3c0a4080a141f173aa6a (diff)
downloadrsyslog-d27edc7587dba7b850759d151d90cdad1cb34a35.tar.gz
rsyslog-d27edc7587dba7b850759d151d90cdad1cb34a35.tar.xz
rsyslog-d27edc7587dba7b850759d151d90cdad1cb34a35.zip
porting parser tests to solaris
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am12
1 files changed, 8 insertions, 4 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 093742db..09d1a0b6 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,9 +1,10 @@
-check_PROGRAMS = rt_init rscript ourtail parsertest
-TESTS = $(check_PROGRAMS) cfg.sh
+TESTRUNS = rt_init rscript parsertest
+check_PROGRAMS = $(TESTRUNS) ourtail
+TESTS = $(TESTRUNS) cfg.sh
TESTS_ENVIRONMENT = RSYSLOG_MODDIR='$(abs_top_builddir)'/runtime/.libs/
DISTCLEANFILES=rsyslog.pid
-
test_files = testbench.h runtime-dummy.c
+
EXTRA_DIST= 1.rstest 2.rstest 3.rstest err1.rstest \
cfg1.cfgtest \
cfg1.testin \
@@ -27,12 +28,15 @@ EXTRA_DIST= 1.rstest 2.rstest 3.rstest err1.rstest \
ourtail_SOURCES = ourtail.c
+parsertest_SOURCES = parsertest.c getline.c
+parsertest_LDADD = $(SOL_LIBS)
+
rt_init_SOURCES = rt-init.c $(test_files)
rt_init_CPPFLAGS = -I$(top_srcdir) $(PTHREADS_CFLAGS) $(RSRT_CFLAGS)
rt_init_LDADD = $(RSRT_LIBS) $(ZLIB_LIBS) $(PTHREADS_LIBS) $(SOL_LIBS)
rt_init_LDFLAGS = -export-dynamic
-rscript_SOURCES = rscript.c $(test_files)
+rscript_SOURCES = rscript.c getline.c $(test_files)
rscript_CPPFLAGS = -I$(top_srcdir) $(PTHREADS_CFLAGS) $(RSRT_CFLAGS)
rscript_LDADD = $(RSRT_LIBS) $(ZLIB_LIBS) $(PTHREADS_LIBS) $(SOL_LIBS)
rscript_LDFLAGS = -export-dynamic