summaryrefslogtreecommitdiffstats
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2010-04-01 15:11:16 +0200
committerRainer Gerhards <rgerhards@adiscon.com>2010-04-01 15:11:16 +0200
commit1cba2162201e98a4a24a3eb19d168c81adf1bbd2 (patch)
treeb3860438eefb1766f17524b5618d1313c1b4934c /tests/Makefile.am
parent302ad02e7781892856c1cacaf98a87f90db9571c (diff)
downloadrsyslog-1cba2162201e98a4a24a3eb19d168c81adf1bbd2.tar.gz
rsyslog-1cba2162201e98a4a24a3eb19d168c81adf1bbd2.tar.xz
rsyslog-1cba2162201e98a4a24a3eb19d168c81adf1bbd2.zip
improvded testbench: added test with truly random data received via syslog to test robustness
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 42ef32e3..76ed694a 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -1,6 +1,6 @@
if ENABLE_TESTBENCH
TESTRUNS = rt_init rscript
-check_PROGRAMS = $(TESTRUNS) ourtail nettester tcpflood chkseq
+check_PROGRAMS = $(TESTRUNS) ourtail nettester tcpflood chkseq randomgen
TESTS = $(TESTRUNS) cfg.sh \
validation-run.sh \
imtcp-multiport.sh \
@@ -24,6 +24,7 @@ TESTS = $(TESTRUNS) cfg.sh \
dynfile_invld_sync.sh \
dynfile_invalid2.sh \
complex1.sh \
+ random.sh \
queue-persist.sh \
pipeaction.sh
execonlyonce.sh \
@@ -180,6 +181,8 @@ EXTRA_DIST= 1.rstest 2.rstest 3.rstest err1.rstest \
testsuites/gzipwr_large_dynfile.conf \
complex1.sh \
testsuites/complex1.conf \
+ random.sh \
+ testsuites/random.conf \
dynfile_invld_async.sh \
dynfile_invld_sync.sh \
dynfile_cachemiss.sh \
@@ -203,6 +206,9 @@ chkseq_SOURCES = chkseq.c
tcpflood_SOURCES = tcpflood.c
tcpflood_LDADD = $(SOL_LIBS)
+randomgen_SOURCES = randomgen.c
+randomgen_LDADD = $(SOL_LIBS)
+
nettester_SOURCES = nettester.c getline.c
nettester_LDADD = $(SOL_LIBS)