summaryrefslogtreecommitdiffstats
path: root/runtime/Makefile.am
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2009-06-03 14:45:09 +0200
committerRainer Gerhards <rgerhards@adiscon.com>2009-06-03 14:45:09 +0200
commitf54e72cec06f21f4af939c70541e8a339b7e56ff (patch)
tree12912644e7d614082ea21715367996e43df3a55d /runtime/Makefile.am
parent4f742a8e32c43dc9b514ceaf80f4d17e697dfdf6 (diff)
downloadrsyslog-f54e72cec06f21f4af939c70541e8a339b7e56ff.tar.gz
rsyslog-f54e72cec06f21f4af939c70541e8a339b7e56ff.tar.xz
rsyslog-f54e72cec06f21f4af939c70541e8a339b7e56ff.zip
first proof of concept on zipped file writer
This DOES NOT work sufficiently well, I just wanted to verify that zip writing is possible and files are readable. Will be refined soon.
Diffstat (limited to 'runtime/Makefile.am')
-rw-r--r--runtime/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/runtime/Makefile.am b/runtime/Makefile.am
index eeb656d6..81422d64 100644
--- a/runtime/Makefile.am
+++ b/runtime/Makefile.am
@@ -105,6 +105,17 @@ lmregexp_la_LDFLAGS = -module -avoid-version
lmregexp_la_LIBADD =
endif
+#
+# zlib support
+#
+if ENABLE_ZLIB
+pkglib_LTLIBRARIES += lmzlibw.la
+lmzlibw_la_SOURCES = zlibw.c zlibw.h
+lmzlibw_la_CPPFLAGS = $(PTHREADS_CFLAGS) $(RSRT_CFLAGS)
+lmzlibw_la_LDFLAGS = -module -avoid-version
+lmzlibw_la_LIBADD =
+endif
+
if ENABLE_INET
pkglib_LTLIBRARIES += lmnet.la lmnetstrms.la
#