summaryrefslogtreecommitdiffstats
path: root/runtime/Makefile.am
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2008-10-22 11:07:21 +0200
committerRainer Gerhards <rgerhards@adiscon.com>2008-10-22 11:07:21 +0200
commitb6f496f8619b02c50d3f5ced34eff279244b6e9b (patch)
treed534a1941848a4f9577076cd11330f3ee014033c /runtime/Makefile.am
parenta27e249e445deecb1d9ef57fbbb203d71bf061dd (diff)
parent162c9e91e970cc9475bc86ffd00fd1d939e1e487 (diff)
downloadrsyslog-b6f496f8619b02c50d3f5ced34eff279244b6e9b.tar.gz
rsyslog-b6f496f8619b02c50d3f5ced34eff279244b6e9b.tar.xz
rsyslog-b6f496f8619b02c50d3f5ced34eff279244b6e9b.zip
Merge branch 'master' into nextmaster
Conflicts: ChangeLog configure.ac
Diffstat (limited to 'runtime/Makefile.am')
-rw-r--r--runtime/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/runtime/Makefile.am b/runtime/Makefile.am
index 7c70dd8d..5e5d08ea 100644
--- a/runtime/Makefile.am
+++ b/runtime/Makefile.am
@@ -85,7 +85,11 @@ librsyslog_la_SOURCES = \
# the files with ../ we need to work on - so that they either become part of the
# runtime or will no longer be needed. -- rgerhards, 2008-06-13
+if WITH_MODDIRS
+librsyslog_la_CPPFLAGS = -D_PATH_MODDIR=\"$(pkglibdir)/:$(moddirs)\" $(pthreads_cflags)
+else
librsyslog_la_CPPFLAGS = -D_PATH_MODDIR=\"$(pkglibdir)/\" -I$(top_srcdir) $(pthreads_cflags)
+endif
#librsyslog_la_LDFLAGS = -module -avoid-version
librsyslog_la_LIBADD = $(dl_libs) $(rt_libs)