summaryrefslogtreecommitdiffstats
path: root/runtime/Makefile.am
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2008-10-08 18:55:11 +0200
committerRainer Gerhards <rgerhards@adiscon.com>2008-10-08 18:55:11 +0200
commitace4f2f75202aec39449dac11b9eb1deca7428d7 (patch)
tree86637d21fafb06b262a30ff2f57dee32cd6483df /runtime/Makefile.am
parent82b583c4f99dd9beb30360f222c4d2a1152f75e1 (diff)
downloadrsyslog-ace4f2f75202aec39449dac11b9eb1deca7428d7.tar.gz
rsyslog-ace4f2f75202aec39449dac11b9eb1deca7428d7.tar.xz
rsyslog-ace4f2f75202aec39449dac11b9eb1deca7428d7.zip
reordered imudp processing.
Message parsing is now done as part of main message queue worker processing (was part of the input thread) This should also improve performance, as potentially more work is done in parallel.
Diffstat (limited to 'runtime/Makefile.am')
-rw-r--r--runtime/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/runtime/Makefile.am b/runtime/Makefile.am
index 81a9d5bd..7c70dd8d 100644
--- a/runtime/Makefile.am
+++ b/runtime/Makefile.am
@@ -16,6 +16,8 @@ librsyslog_la_SOURCES = \
glbl.c \
conf.c \
conf.h \
+ parser.h \
+ parser.c \
msg.c \
msg.h \
linkedlist.c \