summaryrefslogtreecommitdiffstats
path: root/runtime/Makefile.am
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2008-04-17 14:33:43 +0200
committerRainer Gerhards <rgerhards@adiscon.com>2008-04-17 14:33:43 +0200
commit92303d400ba83eaf150054d2cf5ce4906578bed0 (patch)
tree56f8baadfec029e5815bcb097115a0eca40f1720 /runtime/Makefile.am
parentad6b933faf5dfa8f5502969e63eccc86d2af6662 (diff)
downloadrsyslog-92303d400ba83eaf150054d2cf5ce4906578bed0.tar.gz
rsyslog-92303d400ba83eaf150054d2cf5ce4906578bed0.tar.xz
rsyslog-92303d400ba83eaf150054d2cf5ce4906578bed0.zip
added new "netstrm" class (not yet implemented)
Diffstat (limited to 'runtime/Makefile.am')
-rw-r--r--runtime/Makefile.am11
1 files changed, 8 insertions, 3 deletions
diff --git a/runtime/Makefile.am b/runtime/Makefile.am
index 73418fdf..400d78c0 100644
--- a/runtime/Makefile.am
+++ b/runtime/Makefile.am
@@ -75,18 +75,23 @@ if ENABLE_REGEXP
pkglib_LTLIBRARIES += lmregexp.la
lmregexp_la_SOURCES = regexp.c regexp.h
lmregexp_la_CPPFLAGS = $(pthreads_cflags) $(rsrt_cflags)
-lmregexp_la_LDFLAGS = -module -avoid-version $(rsrt_libs)
+lmregexp_la_LDFLAGS = -module -avoid-version
lmregexp_la_LIBADD =
endif
if ENABLE_INET
-pkglib_LTLIBRARIES += lmnet.la
+pkglib_LTLIBRARIES += lmnet.la lmnetstrm.la
#
# network support
#
lmnet_la_SOURCES = net.c net.h
lmnet_la_CPPFLAGS = $(pthreads_cflags) $(rsrt_cflags)
-lmnet_la_LDFLAGS = -module -avoid-version $(rsrt_libs)
+lmnet_la_LDFLAGS = -module -avoid-version
lmnet_la_LIBADD =
+# network streams
+lmnetstrm_la_SOURCES = netstrm.c netstrm.h
+lmnetstrm_la_CPPFLAGS = $(pthreads_cflags) $(rsrt_cflags)
+lmnetstrm_la_LDFLAGS = -module -avoid-version
+lmnetstrm_la_LIBADD =
endif # if ENABLE_INET