summaryrefslogtreecommitdiffstats
path: root/runtime/Makefile.am
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2008-04-17 09:07:12 +0200
committerRainer Gerhards <rgerhards@adiscon.com>2008-04-17 09:07:12 +0200
commit87c936ab65b4381fed35689b38c98f130883d903 (patch)
tree460ca0e1481a62ab9a9728a7e56a74eceb8d2767 /runtime/Makefile.am
parentbf3e0d4f224a26e2ac9bc3edfd1e6eedcf56c9f8 (diff)
downloadrsyslog-87c936ab65b4381fed35689b38c98f130883d903.tar.gz
rsyslog-87c936ab65b4381fed35689b38c98f130883d903.tar.xz
rsyslog-87c936ab65b4381fed35689b38c98f130883d903.zip
modularization work
cleanup + created an abstract class for global data items and moved glblGetWorkDir to it
Diffstat (limited to 'runtime/Makefile.am')
-rw-r--r--runtime/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/runtime/Makefile.am b/runtime/Makefile.am
index 6cd54f91..73418fdf 100644
--- a/runtime/Makefile.am
+++ b/runtime/Makefile.am
@@ -12,6 +12,7 @@ librsyslog_la_SOURCES = \
module-template.h \
obj-types.h \
glbl.h \
+ glbl.c \
msg.c \
msg.h \
linkedlist.c \
@@ -59,7 +60,9 @@ librsyslog_la_SOURCES = \
vmop.c \
vmop.h \
queue.c \
- queue.h
+ queue.h \
+ cfsysline.c \
+ cfsysline.h
librsyslog_la_CPPFLAGS = -D_PATH_MODDIR=\"$(pkglibdir)/\" -I$(top_srcdir) $(pthreads_cflags)
#librsyslog_la_LDFLAGS = -module -avoid-version