summaryrefslogtreecommitdiffstats
path: root/runtime/Makefile.am
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2008-06-13 17:21:03 +0200
committerRainer Gerhards <rgerhards@adiscon.com>2008-06-13 17:21:03 +0200
commit4f32b629906f078ea81637829dde136a27b214e5 (patch)
treec6a4c2830c99575edf7b272a4517d89094bb66b0 /runtime/Makefile.am
parentfa3451aaa466ba7da28de6b324b4f90bab3ad4ef (diff)
downloadrsyslog-4f32b629906f078ea81637829dde136a27b214e5.tar.gz
rsyslog-4f32b629906f078ea81637829dde136a27b214e5.tar.xz
rsyslog-4f32b629906f078ea81637829dde136a27b214e5.zip
begun building a testbench
Diffstat (limited to 'runtime/Makefile.am')
-rw-r--r--runtime/Makefile.am20
1 files changed, 19 insertions, 1 deletions
diff --git a/runtime/Makefile.am b/runtime/Makefile.am
index 79783bd6..81a9d5bd 100644
--- a/runtime/Makefile.am
+++ b/runtime/Makefile.am
@@ -14,6 +14,8 @@ librsyslog_la_SOURCES = \
nsd.h \
glbl.h \
glbl.c \
+ conf.c \
+ conf.h \
msg.c \
msg.h \
linkedlist.c \
@@ -63,7 +65,23 @@ librsyslog_la_SOURCES = \
queue.c \
queue.h \
cfsysline.c \
- cfsysline.h
+ cfsysline.h \
+ \
+ \
+ ../action.h \
+ ../action.c \
+ ../threads.c \
+ ../threads.h \
+ \
+ ../parse.c \
+ ../parse.h \
+ \
+ ../outchannel.c \
+ ../outchannel.h \
+ ../template.c \
+ ../template.h
+# the files with ../ we need to work on - so that they either become part of the
+# runtime or will no longer be needed. -- rgerhards, 2008-06-13
librsyslog_la_CPPFLAGS = -D_PATH_MODDIR=\"$(pkglibdir)/\" -I$(top_srcdir) $(pthreads_cflags)
#librsyslog_la_LDFLAGS = -module -avoid-version