summaryrefslogtreecommitdiffstats
path: root/runtime/Makefile.am
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2008-04-23 09:59:01 +0200
committerRainer Gerhards <rgerhards@adiscon.com>2008-04-23 09:59:01 +0200
commit2be459c4d7645ad12f83723be7bb26199fe98b82 (patch)
tree749db3a20481dea667b5405961c173c4317d9e0d /runtime/Makefile.am
parent22ad77a627fe813acd286b48aaf44945c0480f49 (diff)
downloadrsyslog-2be459c4d7645ad12f83723be7bb26199fe98b82.tar.gz
rsyslog-2be459c4d7645ad12f83723be7bb26199fe98b82.tar.xz
rsyslog-2be459c4d7645ad12f83723be7bb26199fe98b82.zip
objects for receive-side socket abstraction specified
The objects for receiver-side socket abstraction have now be specified. The project as whole does not yet compile and definitely not run, but I'd like to commit some milestones along this way.
Diffstat (limited to 'runtime/Makefile.am')
-rw-r--r--runtime/Makefile.am17
1 files changed, 15 insertions, 2 deletions
diff --git a/runtime/Makefile.am b/runtime/Makefile.am
index 077310c6..61ede1d7 100644
--- a/runtime/Makefile.am
+++ b/runtime/Makefile.am
@@ -81,7 +81,7 @@ lmregexp_la_LIBADD =
endif
if ENABLE_INET
-pkglib_LTLIBRARIES += lmnet.la lmnetstrm.la
+pkglib_LTLIBRARIES += lmnet.la lmnetstrm.la lmnssel.la
#
# network support
#
@@ -96,12 +96,25 @@ lmnetstrm_la_CPPFLAGS = $(pthreads_cflags) $(rsrt_cflags)
lmnetstrm_la_LDFLAGS = -module -avoid-version
lmnetstrm_la_LIBADD =
+# network stream select support (a helper class)
+lmnssel_la_SOURCES = nssel.c nssel.h
+lmnssel_la_CPPFLAGS = $(pthreads_cflags) $(rsrt_cflags)
+lmnssel_la_LDFLAGS = -module -avoid-version
+lmnssel_la_LIBADD =
+
# netstream drivers
-# plain tcp driver
+# plain tcp driver - main driver
pkglib_LTLIBRARIES += lmnsd_ptcp.la
lmnsd_ptcp_la_SOURCES = nsd_ptcp.c nsd_ptcp.h
lmnsd_ptcp_la_CPPFLAGS = $(pthreads_cflags) $(rsrt_cflags)
lmnsd_ptcp_la_LDFLAGS = -module -avoid-version
lmnsd_ptcp_la_LIBADD =
+
+# select interface for ptcp driver
+pkglib_LTLIBRARIES += lmnsdsel_ptcp.la
+lmnsdsel_ptcp_la_SOURCES = nsdsel_ptcp.c nsdsel_ptcp.h
+lmnsdsel_ptcp_la_CPPFLAGS = $(pthreads_cflags) $(rsrt_cflags)
+lmnsdsel_ptcp_la_LDFLAGS = -module -avoid-version
+lmnsdsel_ptcp_la_LIBADD =
endif # if ENABLE_INET