summaryrefslogtreecommitdiffstats
path: root/runtime/Makefile.am
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2008-04-18 18:29:02 +0200
committerRainer Gerhards <rgerhards@adiscon.com>2008-04-18 18:29:02 +0200
commit2069ab114e2aac9c243aff72042912cac7ef6126 (patch)
tree19bd5df7fb640b754ec6b91954d0153ed0f2eac5 /runtime/Makefile.am
parent032b9c1f64691e868b14e6d271ebfc2d093b0c66 (diff)
downloadrsyslog-2069ab114e2aac9c243aff72042912cac7ef6126.tar.gz
rsyslog-2069ab114e2aac9c243aff72042912cac7ef6126.tar.xz
rsyslog-2069ab114e2aac9c243aff72042912cac7ef6126.zip
first working TLS-enabled plain TCP sender
implemented a first working version of a TLS-enabled plain TCP sender (but, of course, the implementation is insecure as it is)
Diffstat (limited to 'runtime/Makefile.am')
-rw-r--r--runtime/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/runtime/Makefile.am b/runtime/Makefile.am
index 23e62deb..1d07e79c 100644
--- a/runtime/Makefile.am
+++ b/runtime/Makefile.am
@@ -110,8 +110,8 @@ endif # if ENABLE_INET
if ENABLE_GNUTLS
pkglib_LTLIBRARIES += lmnsd_gtls.la
lmnsd_gtls_la_SOURCES = nsd_gtls.c nsd_gtls.h
-lmnsd_gtls_la_CPPFLAGS = $(pthreads_cflags) $(rsrt_cflags)
+lmnsd_gtls_la_CPPFLAGS = $(pthreads_cflags) $(rsrt_cflags) $(gnutls_cflags)
lmnsd_gtls_la_LDFLAGS = -module -avoid-version
-lmnsd_gtls_la_LIBADD =
+lmnsd_gtls_la_LIBADD = $(gnutls_libs)
endif