summaryrefslogtreecommitdiffstats
path: root/runtime/Makefile.am
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2008-04-18 11:40:15 +0200
committerRainer Gerhards <rgerhards@adiscon.com>2008-04-18 11:40:15 +0200
commit1daf8d492f932739b6fcde732812116c7666b2bc (patch)
tree24dd3b699f1e4277919a64f4d9f513e1821b7b01 /runtime/Makefile.am
parentea4a3a3cd95faf9328def84e3e253d6c1a4375f7 (diff)
downloadrsyslog-1daf8d492f932739b6fcde732812116c7666b2bc.tar.gz
rsyslog-1daf8d492f932739b6fcde732812116c7666b2bc.tar.xz
rsyslog-1daf8d492f932739b6fcde732812116c7666b2bc.zip
converted netstrm into generic netstrm and the nsd_pctp driver
Diffstat (limited to 'runtime/Makefile.am')
-rw-r--r--runtime/Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/runtime/Makefile.am b/runtime/Makefile.am
index 400d78c0..077310c6 100644
--- a/runtime/Makefile.am
+++ b/runtime/Makefile.am
@@ -11,6 +11,7 @@ librsyslog_la_SOURCES = \
syslogd-types.h \
module-template.h \
obj-types.h \
+ nsd.h \
glbl.h \
glbl.c \
msg.c \
@@ -94,4 +95,13 @@ lmnetstrm_la_SOURCES = netstrm.c netstrm.h
lmnetstrm_la_CPPFLAGS = $(pthreads_cflags) $(rsrt_cflags)
lmnetstrm_la_LDFLAGS = -module -avoid-version
lmnetstrm_la_LIBADD =
+
+# netstream drivers
+
+# plain tcp driver
+pkglib_LTLIBRARIES += lmnsd_ptcp.la
+lmnsd_ptcp_la_SOURCES = nsd_ptcp.c nsd_ptcp.h
+lmnsd_ptcp_la_CPPFLAGS = $(pthreads_cflags) $(rsrt_cflags)
+lmnsd_ptcp_la_LDFLAGS = -module -avoid-version
+lmnsd_ptcp_la_LIBADD =
endif # if ENABLE_INET