summaryrefslogtreecommitdiffstats
path: root/runtime/Makefile.am
diff options
context:
space:
mode:
authorMarius Tomaschewski <mt@suse.de>2008-10-20 17:36:31 +0200
committerRainer Gerhards <rgerhards@adiscon.com>2008-10-20 17:36:31 +0200
commit19ccebbf4c49c5f9954c7a1a092399303156a1f3 (patch)
tree026156076969b9bccfc575260b167068d9403bc6 /runtime/Makefile.am
parent8892c5293248d730907bed5f956cbcfa2938fc6e (diff)
downloadrsyslog-19ccebbf4c49c5f9954c7a1a092399303156a1f3.tar.gz
rsyslog-19ccebbf4c49c5f9954c7a1a092399303156a1f3.tar.xz
rsyslog-19ccebbf4c49c5f9954c7a1a092399303156a1f3.zip
added capability to support multiple module search pathes.
Signed-off-by: Rainer Gerhards <rgerhards@adiscon.com>
Diffstat (limited to 'runtime/Makefile.am')
-rw-r--r--runtime/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/runtime/Makefile.am b/runtime/Makefile.am
index 81a9d5bd..8dd8ad12 100644
--- a/runtime/Makefile.am
+++ b/runtime/Makefile.am
@@ -83,7 +83,11 @@ librsyslog_la_SOURCES = \
# the files with ../ we need to work on - so that they either become part of the
# runtime or will no longer be needed. -- rgerhards, 2008-06-13
+if WITH_MODDIRS
+librsyslog_la_CPPFLAGS = -D_PATH_MODDIR=\"$(pkglibdir)/:$(moddirs)\" $(pthreads_cflags)
+else
librsyslog_la_CPPFLAGS = -D_PATH_MODDIR=\"$(pkglibdir)/\" -I$(top_srcdir) $(pthreads_cflags)
+endif
#librsyslog_la_LDFLAGS = -module -avoid-version
librsyslog_la_LIBADD = $(dl_libs) $(rt_libs)