summaryrefslogtreecommitdiffstats
path: root/plugins/omstdout/Makefile.am
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2009-03-19 17:50:07 +0100
committerRainer Gerhards <rgerhards@adiscon.com>2009-03-19 17:50:07 +0100
commitbbfa04fbe63f1bbb47f5cdc683045cf2775b3977 (patch)
tree1321c8edd1daede54d7b9680fc58ebd5cca1ead9 /plugins/omstdout/Makefile.am
parent790532bb834e3d4fc07273b2d72127e39ef3e142 (diff)
downloadrsyslog-bbfa04fbe63f1bbb47f5cdc683045cf2775b3977.tar.gz
rsyslog-bbfa04fbe63f1bbb47f5cdc683045cf2775b3977.tar.xz
rsyslog-bbfa04fbe63f1bbb47f5cdc683045cf2775b3977.zip
improved testing support
worked on ways to provide a better test suite: - added -T rsyslogd command line option, enables to specify a directory where to chroot() into on startup. This is NOT a security feature but introduced to support testing. Thus, -T does not make sure chroot() is used in a secure way. (may be removed later) - added omstdout module for testing purposes. Spits out all messages to stdout - no config option, no other features - modified $ModLoad statement so that for modules whom's name starts with a dot, no path is prepended (this enables relative-pathes and should not break any valid current config)
Diffstat (limited to 'plugins/omstdout/Makefile.am')
-rw-r--r--plugins/omstdout/Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/plugins/omstdout/Makefile.am b/plugins/omstdout/Makefile.am
new file mode 100644
index 00000000..9f5d497f
--- /dev/null
+++ b/plugins/omstdout/Makefile.am
@@ -0,0 +1,8 @@
+pkglib_LTLIBRARIES = omstdout.la
+
+omstdout_la_SOURCES = omstdout.c
+omstdout_la_CPPFLAGS = $(RSRT_CFLAGS) $(PTHREADS_CFLAGS)
+omstdout_la_LDFLAGS = -module -avoid-version
+omstdout_la_LIBADD =
+
+EXTRA_DIST =