summaryrefslogtreecommitdiffstats
path: root/plugins/omhdfs/Makefile.am
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2010-09-30 13:55:26 +0000
committerRainer Gerhards <rgerhards@adiscon.com>2010-09-30 13:55:26 +0000
commit7ac7ad166b82034eea4a37c1937ca5ddd618ec45 (patch)
tree91c4467d8e595577eb2133318ec4ba465707edbe /plugins/omhdfs/Makefile.am
parent11617d8ab5192c12e3b33cd9c08ac32f1d334a85 (diff)
downloadrsyslog-7ac7ad166b82034eea4a37c1937ca5ddd618ec45.tar.gz
rsyslog-7ac7ad166b82034eea4a37c1937ca5ddd618ec45.tar.xz
rsyslog-7ac7ad166b82034eea4a37c1937ca5ddd618ec45.zip
omhdfs: added "real" libhdfs code, now actually works on hdfs
very crude implementation, but probably good enough to gather some early performance data and experience with the module. No real error handling done, if something breaks, the whole thing will be blown up ;)
Diffstat (limited to 'plugins/omhdfs/Makefile.am')
-rw-r--r--plugins/omhdfs/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/plugins/omhdfs/Makefile.am b/plugins/omhdfs/Makefile.am
index 329e6816..23fcf75a 100644
--- a/plugins/omhdfs/Makefile.am
+++ b/plugins/omhdfs/Makefile.am
@@ -1,6 +1,6 @@
pkglib_LTLIBRARIES = omhdfs.la
omhdfs_la_SOURCES = omhdfs.c
-omhdfs_la_CPPFLAGS = -I$(top_srcdir) $(PTHREADS_CFLAGS) $(RSRT_CFLAGS)
-omhdfs_la_LDFLAGS = -module -avoid-version
+omhdfs_la_CPPFLAGS = -I$(top_srcdir) $(PTHREADS_CFLAGS) $(RSRT_CFLAGS) -I/usr/lib/jvm/java-6-sun/include -I/usr/lib/jvm/java-6-sun/include/linux
+omhdfs_la_LDFLAGS = -module -avoid-version -lhdfs -L/usr/lib/jvm/java-6-sun-1.6.0.20/jre/lib/amd64 -L/usr/lib/jvm/java-6-sun-1.6.0.20/jre/lib/amd64/server -ljava -ljvm -lverify
omhdfs_la_LIBADD =