summaryrefslogtreecommitdiffstats
path: root/plugins/imklog/Makefile.am
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2012-01-23 18:05:07 +0100
committerRainer Gerhards <rgerhards@adiscon.com>2012-01-23 18:05:07 +0100
commit01405d78f4a8c090d5abe37380d60cff252efdc6 (patch)
tree6fcbe263118c29488da28cb1a5893f89cad804a9 /plugins/imklog/Makefile.am
parentef34821a2737799f48c3032b9616418e4f7fa34f (diff)
downloadrsyslog-01405d78f4a8c090d5abe37380d60cff252efdc6.tar.gz
rsyslog-01405d78f4a8c090d5abe37380d60cff252efdc6.tar.xz
rsyslog-01405d78f4a8c090d5abe37380d60cff252efdc6.zip
refactored imklog linux driver, now combined with BSD driver
The Linux driver no longer supports outdated kernel symbol resolution, which was disabled by default for very long. Also overall cleanup, resulting in much smaller code. Linux and BSD are now covered by a single small driver.
Diffstat (limited to 'plugins/imklog/Makefile.am')
-rw-r--r--plugins/imklog/Makefile.am3
1 files changed, 1 insertions, 2 deletions
diff --git a/plugins/imklog/Makefile.am b/plugins/imklog/Makefile.am
index 5d4d0465..7d0d37c9 100644
--- a/plugins/imklog/Makefile.am
+++ b/plugins/imklog/Makefile.am
@@ -1,5 +1,4 @@
pkglib_LTLIBRARIES = imklog.la
-
imklog_la_SOURCES = imklog.c imklog.h
# select klog "driver"
@@ -8,7 +7,7 @@ imklog_la_SOURCES += bsd.c
endif
if ENABLE_IMKLOG_LINUX
-imklog_la_SOURCES += linux.c module.h ksym.c ksyms.h ksym_mod.c
+imklog_la_SOURCES += bsd.c
endif
imklog_la_CPPFLAGS = -I$(top_srcdir) $(PTHREADS_CFLAGS) $(RSRT_CFLAGS)