summaryrefslogtreecommitdiffstats
path: root/grammar/Makefile.am
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2011-07-05 11:04:47 +0200
committerRainer Gerhards <rgerhards@adiscon.com>2011-07-05 11:04:47 +0200
commit6175ce90b59d742976aa5a8b2603902761e540ae (patch)
tree4a680c6f0cb3cc22007aac1907e9c74fd22deae3 /grammar/Makefile.am
parent641e383b8ad13ad6ee7fd9241214e24e6a983500 (diff)
downloadrsyslog-6175ce90b59d742976aa5a8b2603902761e540ae.tar.gz
rsyslog-6175ce90b59d742976aa5a8b2603902761e540ae.tar.xz
rsyslog-6175ce90b59d742976aa5a8b2603902761e540ae.zip
milestone: improved build system
... still had quite some glitches, as usual. This time it hopefully works under all circumstances (well, let's hope for "usual cir..." ;)).
Diffstat (limited to 'grammar/Makefile.am')
-rw-r--r--grammar/Makefile.am13
1 files changed, 11 insertions, 2 deletions
diff --git a/grammar/Makefile.am b/grammar/Makefile.am
index b2bd3430..b482c99e 100644
--- a/grammar/Makefile.am
+++ b/grammar/Makefile.am
@@ -1,7 +1,16 @@
+BUILT_SOURCES = grammar.h
+CLEANFILES = grammar.h grammar.c
+AM_YFLAGS = -d
noinst_LTLIBRARIES = libgrammar.la
+bin_PROGRAMS = testdriver # TODO: make this conditional
libgrammar_la_SOURCES = \
+ grammar.y \
+ lexer.l \
utils.c \
utils.h \
- rscript-lex.l \
- rscript.y
+ grammar.h
+
+testdriver_SOURCES = testdriver.c libgrammar.la
+testdriver_LDADD = libgrammar.la
+testdriver_LDFLAGS = -lestr