summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2008-04-15 14:37:09 +0200
committerRainer Gerhards <rgerhards@adiscon.com>2008-04-15 14:37:09 +0200
commite82c6eec6f91e9c212103d81fdd4b10028c9bf6a (patch)
tree157a358cdef97a1d5e97e9b446b9bf7ccfa95d26 /configure.ac
parent61ba5ff5955742b68a24d7b135ad07c29b48fa2f (diff)
parentb9198d251218f13803cf121c4ef5f69a0e850d24 (diff)
downloadrsyslog-e82c6eec6f91e9c212103d81fdd4b10028c9bf6a.tar.gz
rsyslog-e82c6eec6f91e9c212103d81fdd4b10028c9bf6a.tar.xz
rsyslog-e82c6eec6f91e9c212103d81fdd4b10028c9bf6a.zip
Merge branch 'bsd-port'
Conflicts: ChangeLog plugins/imklog/imklog.c
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 8 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 4f3459c3..e3cfd9fc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2,7 +2,7 @@
# Process this file with autoconf to produce a configure script.
AC_PREREQ(2.61)
-AC_INIT([rsyslog],[3.17.1],[rsyslog@lists.adiscon.com])
+AC_INIT([rsyslog],[3.17.1-bsd],[rsyslog@lists.adiscon.com])
AM_INIT_AUTOMAKE
AC_CONFIG_SRCDIR([syslogd.c])
AC_CONFIG_HEADERS([config.h])
@@ -21,9 +21,11 @@ AC_CANONICAL_HOST
case "${host}" in
*-*-linux*)
+ os_type="linux"
;;
*-*-*darwin*|*-*-freebsd*|*-*-netbsd*|*-*-openbsd*)
- AC_DEFINE([BSD], [1], [Description])
+ AC_DEFINE([OS_BSD], [1], [Indicator for a BSD OS])
+ os_type="bsd"
;;
esac
@@ -218,7 +220,9 @@ AC_ARG_ENABLE(klog,
esac],
[enable_klog="yes"]
)
-AM_CONDITIONAL(ENABLE_IMKLOGD, test x$enable_klog = xyes)
+AM_CONDITIONAL(ENABLE_IMKLOG, test x$enable_klog = xyes)
+AM_CONDITIONAL(ENABLE_IMKLOG_BSD, test x$os_type = xbsd)
+AM_CONDITIONAL(ENABLE_IMKLOG_LINUX, test x$os_type = xlinux)
#
# SYSLOG_UNIXAF
@@ -635,7 +639,7 @@ echo "****************************************************"
echo "rsyslog will be compiled with the following settings:"
echo
echo "Multithreading support enabled: $enable_pthreads"
-echo "Klog functionality enabled: $enable_klog"
+echo "Klog functionality enabled: $enable_klog ($os_type)"
echo "Regular expressions support enabled: $enable_regexp"
echo "Zlib compression support enabled: $enable_zlib"
echo "MySql support enabled: $enable_mysql"