summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2008-04-15 18:49:05 +0200
committerRainer Gerhards <rgerhards@adiscon.com>2008-04-15 18:49:05 +0200
commitdfc9733135787a4b89dde3950273d3a1b1a26604 (patch)
treec29f44f8de713b965830ade6fd273714ba521247 /configure.ac
parent0e83bd69fcce2359d1d25022d1cc1263e42219a9 (diff)
downloadrsyslog-dfc9733135787a4b89dde3950273d3a1b1a26604.tar.gz
rsyslog-dfc9733135787a4b89dde3950273d3a1b1a26604.tar.xz
rsyslog-dfc9733135787a4b89dde3950273d3a1b1a26604.zip
begun re-integrating rfc3195 in rsyslog
set up build system and shuffle some files
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 5 insertions, 18 deletions
diff --git a/configure.ac b/configure.ac
index 2a5ef16b..732e5a82 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2,7 +2,7 @@
# Process this file with autoconf to produce a configure script.
AC_PREREQ(2.61)
-AC_INIT([rsyslog],[3.17.1],[rsyslog@lists.adiscon.com])
+AC_INIT([rsyslog],[3.17.2],[rsyslog@lists.adiscon.com])
AM_INIT_AUTOMAKE
AC_CONFIG_SRCDIR([syslogd.c])
AC_CONFIG_HEADERS([config.h])
@@ -553,25 +553,11 @@ AC_ARG_ENABLE(rfc3195,
[enable_rfc3195=no]
)
if test "x$enable_rfc3195" = "xyes"; then
- AC_CHECK_HEADERS(
- [librfc3195.h],,
- [AC_MSG_FAILURE([RFC3195 library is missing (no headers)])]
- )
-# I don't know how to tell that librfc3195 needs -lrt, so I disable
-# this check for now - the header check should work well enough...
-# rgerhards, 2008-03-25
-# AC_CHECK_LIB(
-# [rfc3195],
-# [rfc3195EngineGetVersion],
-# [rfc3195_cflags=""
- rfc3195_libs="-lrfc3195"
-# ],
-# [AC_MSG_FAILURE([RFC3195 library is missing])]
-# )
+ PKG_CHECK_MODULES(LIBLOGGING, liblogging >= 0.7.0)
fi
AM_CONDITIONAL(ENABLE_RFC3195, test x$enable_rfc3195 = xyes)
-AC_SUBST(rfc3195_cflags)
-AC_SUBST(rfc3195_libs)
+AC_SUBST(RFC3195_CFLAGS)
+AC_SUBST(RFC3195_LIBS)
# settings for the template input module; copy and modify this code
@@ -618,6 +604,7 @@ AC_CONFIG_FILES([Makefile \
doc/Makefile \
plugins/imudp/Makefile \
plugins/imtcp/Makefile \
+ plugins/im3195/Makefile \
plugins/imgssapi/Makefile \
plugins/imuxsock/Makefile \
plugins/immark/Makefile \