summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2008-04-04 13:34:47 +0000
committerRainer Gerhards <rgerhards@adiscon.com>2008-04-04 13:34:47 +0000
commitc0c9f44966b00bba9c3eaa962cdf6f0010a8f781 (patch)
tree7d85b0924f99c6bfb97c66ea391eb27f5e8fed19 /configure.ac
parent5ba8b2c77c3971a69bde54f3dd0ede81e641d798 (diff)
downloadrsyslog-c0c9f44966b00bba9c3eaa962cdf6f0010a8f781.tar.gz
rsyslog-c0c9f44966b00bba9c3eaa962cdf6f0010a8f781.tar.xz
rsyslog-c0c9f44966b00bba9c3eaa962cdf6f0010a8f781.zip
begun work on mail output plugin (open questions on TLS, so I see if I can
put this in between) - does not the least yet work ;)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8b407ccf..a938eae2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -491,6 +491,19 @@ AC_ARG_ENABLE(rsyslogd,
AM_CONDITIONAL(ENABLE_RSYSLOGD, test x$enable_rsyslogd = xyes)
+# Mail support (so far we do not need a library, but we need to turn this on and off)
+AC_ARG_ENABLE(mail,
+ [AS_HELP_STRING([--enable-mail],[Enable mail support @<:@default=no@:>@])],
+ [case "${enableval}" in
+ yes) enable_mail="yes" ;;
+ no) enable_mail="no" ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --enable-mail) ;;
+ esac],
+ [enable_mail=no]
+)
+AM_CONDITIONAL(ENABLE_MAIL, test x$enable_mail = xyes)
+
+
# RELP support
AC_ARG_ENABLE(relp,
[AS_HELP_STRING([--enable-relp],[Enable RELP support @<:@default=no@:>@])],
@@ -598,6 +611,7 @@ AC_CONFIG_FILES([Makefile \
plugins/ompgsql/Makefile \
plugins/omrelp/Makefile \
plugins/omlibdbi/Makefile \
+ plugins/ommail/Makefile \
plugins/omsnmp/Makefile])
AC_OUTPUT
@@ -612,6 +626,7 @@ echo "MySql support enabled: $enable_mysql"
echo "libdbi support enabled: $enable_libdbi"
echo "PostgreSQL support enabled: $enable_pgsql"
echo "SNMP support enabled: $enable_snmp"
+echo "Mail support enabled: $enable_mail"
echo "RELP support enabled: $enable_relp"
echo "file input module enabled: $enable_imfile"
echo "input template module will be compiled: $enable_imtemplate"