summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2011-05-20 11:48:17 +0200
committerRainer Gerhards <rgerhards@adiscon.com>2011-05-20 11:48:17 +0200
commitac32d356b5b776e0ca549d5c689a8932af4c2171 (patch)
treed8aa8631ec9b7aae850801be4076d71a652e483e /configure.ac
parentfd4a54698cee48da073622f7d6ac49c94ccb1808 (diff)
parent1d86889922cb9232819b4451afce091e8a0ad938 (diff)
downloadrsyslog-ac32d356b5b776e0ca549d5c689a8932af4c2171.tar.gz
rsyslog-ac32d356b5b776e0ca549d5c689a8932af4c2171.tar.xz
rsyslog-ac32d356b5b776e0ca549d5c689a8932af4c2171.zip
Merge branch 'v5-stable' into beta
Conflicts: ChangeLog configure.ac doc/manual.html doc/rsyslog_conf_modules.html plugins/imrelp/imrelp.c
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8bdf1395..5d00737f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1171,6 +1171,19 @@ AM_CONDITIONAL(ENABLE_OMTEMPLATE, test x$enable_omtemplate = xyes)
# end of copy template - be sure to search for omtemplate to find everything!
+# settings for mmsnmptrapd message modification module
+AC_ARG_ENABLE(mmsnmptrapd,
+ [AS_HELP_STRING([--enable-mmsnmptrapd],[Compiles mmsnmptrapd module @<:@default=no@:>@])],
+ [case "${enableval}" in
+ yes) enable_mmsnmptrapd="yes" ;;
+ no) enable_mmsnmptrapd="no" ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --enable-mmsnmptrapd) ;;
+ esac],
+ [enable_mmsnmptrapd=no]
+)
+AM_CONDITIONAL(ENABLE_MMSNMPTRAPD, test x$enable_mmsnmptrapd = xyes)
+
+
# settings for the omhdfs;
AC_ARG_ENABLE(omhdfs,
[AS_HELP_STRING([--enable-omhdfs],[Compiles omhdfs template module @<:@default=no@:>@])],
@@ -1250,6 +1263,7 @@ AC_CONFIG_FILES([Makefile \
plugins/omudpspoof/Makefile \
plugins/mmnormalize/Makefile \
plugins/sm_cust_bindcdr/Makefile \
+ plugins/mmsnmptrapd/Makefile \
plugins/cust1/Makefile \
java/Makefile \
tests/Makefile])
@@ -1299,6 +1313,7 @@ echo " pmsnare module will be compiled: $enable_pmsnare"
echo
echo "---{ message modification modules }---"
echo " mmnormalize module will be compiled: $enable_mmnormalize"
+echo " mmsnmptrapd module will be compiled: $enable_mmsnmptrapd"
echo
echo "---{ strgen modules }---"
echo " sm_cust_bindcdr module will be compiled: $enable_sm_cust_bindcdr"