summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2009-08-25 12:14:50 +0200
committerRainer Gerhards <rgerhards@adiscon.com>2009-08-25 12:14:50 +0200
commit8c125325cf239d7303e0f479b284fd1f59c223f7 (patch)
treee6c336deedb753f23e87c54b638480640f6b0559 /configure.ac
parent03918b4478f5523873af32e3f9a62222f5ab7f20 (diff)
downloadrsyslog-8c125325cf239d7303e0f479b284fd1f59c223f7.tar.gz
rsyslog-8c125325cf239d7303e0f479b284fd1f59c223f7.tar.xz
rsyslog-8c125325cf239d7303e0f479b284fd1f59c223f7.zip
features requiring Java are automatically disabled if Java is not present
(thanks to Michael Biebl for his help!)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6be11b0d..fec55863 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10,6 +10,12 @@ AC_CONFIG_HEADERS([config.h])
AC_GNU_SOURCE
+# check for Java compiler
+AC_CHECK_PROG(HAVE_JAVAC, [javac], [yes])
+if test x"$HAVE_JAVAC" = x"yes"; then
+ AC_MSG_WARN([no javac found, disabling features depending on it])
+fi
+
# Checks for programs.
AC_PROG_CC
AM_PROG_CC_C_O
@@ -689,6 +695,11 @@ AC_ARG_ENABLE(testbench,
esac],
[enable_testbench=yes]
)
+if test "$enable_testbench" = "yes"; then
+ if test x$HAVE_JAVAC = x; then
+ enable_testbench='no'
+ fi
+fi
AM_CONDITIONAL(ENABLE_TESTBENCH, test x$enable_testbench = xyes)