summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Biebl <mbiebl@gmail.com>2008-07-05 01:22:40 +0200
committerRainer Gerhards <rgerhards@adiscon.com>2008-07-10 09:12:11 +0200
commit82c8077b91ab5c1928b3d712d3ab61e4041c461d (patch)
tree2f8bd50c4c82b5281e2ca5a59e16793ef58c35fc /configure.ac
parent935157d45a01480627950bd8c97f55fe51a8983c (diff)
downloadrsyslog-82c8077b91ab5c1928b3d712d3ab61e4041c461d.tar.gz
rsyslog-82c8077b91ab5c1928b3d712d3ab61e4041c461d.tar.xz
rsyslog-82c8077b91ab5c1928b3d712d3ab61e4041c461d.zip
Remove unnecessary openssl configure check.
Signed-off-by: Rainer Gerhards <rgerhards@adiscon.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac37
1 files changed, 0 insertions, 37 deletions
diff --git a/configure.ac b/configure.ac
index f1a94dae..1504b025 100644
--- a/configure.ac
+++ b/configure.ac
@@ -433,42 +433,6 @@ AC_SUBST(libdbi_cflags)
AC_SUBST(libdbi_libs)
-# openssl support
-AC_ARG_ENABLE(openssl,
- [AS_HELP_STRING([--enable-openssl],[Enable openssl support @<:@default=yes@:>@])],
- [case "${enableval}" in
- yes) enable_openssl="yes" ;;
- no) enable_openssl="no" ;;
- *) AC_MSG_ERROR(bad value ${enableval} for --enable-openssl) ;;
- esac],
- [enable_openssl=no]
-)
-if test "x$enable_openssl" = "xyes"; then
- AC_CHECK_HEADERS(
- [openssl/ssl.h],,
- [AC_MSG_FAILURE([openssl is missing])]
- )
- AC_CHECK_LIB(
- [crypto],
- [CRYPTO_new_ex_data],
- [openssl_cflags=""
- openssl_libs="-lcrypto"
- ],
- [AC_MSG_FAILURE([library 'crypto' is missing (needed for openssl)])]
- )
- AC_CHECK_LIB(
- [ssl],
- [SSL_library_init],
- [ openssl_libs+="-lssl"
- ],
- [AC_MSG_FAILURE([library 'ssl' is missing (needed for openssl)])]
- )
-fi
-AM_CONDITIONAL(ENABLE_OPENSSL, test x$enable_openssl = xyes)
-AC_SUBST(openssl_cflags)
-AC_SUBST(openssl_libs)
-
-
# SNMP support
AC_ARG_ENABLE(snmp,
[AS_HELP_STRING([--enable-snmp],[Enable SNMP support @<:@default=no@:>@])],
@@ -655,7 +619,6 @@ echo "Networking support enabled: $enable_inet"
echo "Enable GSSAPI Kerberos 5 support: $want_gssapi_krb5"
echo "Debug mode enabled: $enable_debug"
echo "Runtime Instrumentation enabled: $enable_rtinst"
-echo "openssl enabled: $enable_openssl"
echo "valgrind support settings enabled: $enable_valgrind"
echo "rsyslogd will be built: $enable_rsyslogd"