summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2008-03-29 10:23:09 +0000
committerRainer Gerhards <rgerhards@adiscon.com>2008-03-29 10:23:09 +0000
commit4d2140ce0589c5c7ce33683211887468f82292ce (patch)
tree3615c35c4ce368800827a9b46b99d7557144853d /configure.ac
parent3308c71ec8b5b8f61af4747a8cf9a651daf69c6d (diff)
downloadrsyslog-4d2140ce0589c5c7ce33683211887468f82292ce.tar.gz
rsyslog-4d2140ce0589c5c7ce33683211887468f82292ce.tar.xz
rsyslog-4d2140ce0589c5c7ce33683211887468f82292ce.zip
- bugfix: accidently set debug option in 3.12.5 reset to production This
option prevented dlclose() to be called. It had no real bad effects, as the modules were otherwise correctly deinitialized and dlopen() supports multiple opens of the same module without any memory footprint. - removed --enable-mudflap, added --enable-valgrind ./configure setting
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 10 insertions, 12 deletions
diff --git a/configure.ac b/configure.ac
index 85c9bc56..e87ca184 100644
--- a/configure.ac
+++ b/configure.ac
@@ -291,20 +291,18 @@ if test "$enable_rtinst" = "yes"; then
AC_DEFINE(RTINST, 1, [Defined if runtime instrumentation mode is enabled.])
fi
-# mudflap
-AC_ARG_ENABLE(mudflap,
- [AS_HELP_STRING([--enable-mudflap],[Enable mudflap @<:@default=no@:>@])],
+# valgrind
+AC_ARG_ENABLE(valgrind,
+ [AS_HELP_STRING([--enable-valgrind],[Enable valgrind support settings @<:@default=no@:>@])],
[case "${enableval}" in
- yes) enable_mudflap="yes" ;;
- no) enable_mudflap="no" ;;
- *) AC_MSG_ERROR(bad value ${enableval} for --enable-mudflap) ;;
+ yes) enable_valgrind="yes" ;;
+ no) enable_valgrind="no" ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --enable-valgrind) ;;
esac],
- [enable_mudflap="no"]
+ [enable_valgrind="no"]
)
-if test "$enable_mudflap" = "yes"; then
- # is there any way to just change the -O option in default CFLAGS? -- rgerhards, 2008-01-08
- CFLAGS="-fmudflapth $CFLAGS"
- LIBS="-lmudflapth $LIBS"
+if test "$enable_valgrind" = "yes"; then
+ AC_DEFINE(VALGRIND, 1, [Defined if valgrind support settings are to be enabled (e.g. prevents dlclose()).])
fi
@@ -555,5 +553,5 @@ echo "Networking support enabled: $enable_inet"
echo "Enable GSSAPI Kerberos 5 support: $want_gssapi_krb5"
echo "Debug mode enabled: $enable_debug"
echo "Runtime Instrumentation enabled: $enable_rtinst"
-echo "Mudflap enabled: $enable_mudflap"
+echo "valgrind support settings enabled: $enable_valgrind"