summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2008-04-02 08:05:31 +0000
committerRainer Gerhards <rgerhards@adiscon.com>2008-04-02 08:05:31 +0000
commit35dc817c008cd54175cd2d6c747119a7cf1922c1 (patch)
tree51c71fd31fe5a4c3be901dc30e2c721fbc324b40 /configure.ac
parent565c2b5cd87cd31781abf2116edef48afecdf9d4 (diff)
downloadrsyslog-35dc817c008cd54175cd2d6c747119a7cf1922c1.tar.gz
rsyslog-35dc817c008cd54175cd2d6c747119a7cf1922c1.tar.xz
rsyslog-35dc817c008cd54175cd2d6c747119a7cf1922c1.zip
added librelp check via PKG_CHECK thanks to Michael Biebl's patch
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 3 insertions, 18 deletions
diff --git a/configure.ac b/configure.ac
index ca2cf484..498957da 100644
--- a/configure.ac
+++ b/configure.ac
@@ -466,26 +466,11 @@ AC_ARG_ENABLE(relp,
[enable_relp=no]
)
if test "x$enable_relp" = "xyes"; then
- AC_CHECK_HEADERS(
- [librelp.h],,
- [AC_MSG_FAILURE([RELP library is missing (no headers)])]
- )
-# I don't know how to tell that librelp needs -lrt, so I disable
-# this check for now - the header check should work well enough...
-# rgerhards, 2008-03-25
-# AC_CHECK_LIB(
-# [relp],
-# [relpEngineGetVersion],
-# [relp_cflags=""
- relp_libs="-lrelp"
-# ],
-# [AC_MSG_FAILURE([RELP library is missing])]
-# )
+ PKG_CHECK_MODULES(RELP, relp)
fi
AM_CONDITIONAL(ENABLE_RELP, test x$enable_relp = xyes)
-AC_SUBST(relp_cflags)
-AC_SUBST(relp_libs)
-
+AC_SUBST(RELP_CFLAGS)
+AC_SUBST(RELP_LIBS)
# RFC 3195 support
# WARNING: THIS IS NOT REALLY PRESENT YET - needs to be build manually!