summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2010-08-11 11:49:32 +0200
committerRainer Gerhards <rgerhards@adiscon.com>2010-08-11 11:49:32 +0200
commit32e715929f5d946d7244db3bc0595842dd293dd9 (patch)
tree2a154cd6984690e91569feebcd6924efa0eb91b7 /configure.ac
parent89f7dddf36d57c9261464560e3b2c0fb8ea88fd2 (diff)
parentc664adfa1683763ae503f2da9e8d4d528d6634d1 (diff)
downloadrsyslog-32e715929f5d946d7244db3bc0595842dd293dd9.tar.gz
rsyslog-32e715929f5d946d7244db3bc0595842dd293dd9.tar.xz
rsyslog-32e715929f5d946d7244db3bc0595842dd293dd9.zip
Merge branch 'v4-stable-imptcp' into tmp
Conflicts: Makefile.am configure.ac runtime/rsyslog.h tests/Makefile.am
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ffbefa60..27c8d69f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -759,6 +759,18 @@ AC_ARG_ENABLE(imsolaris,
)
AM_CONDITIONAL(ENABLE_IMSOLARIS, test x$enable_imsolaris = xyes)
+# settings for the ptcp input module
+AC_ARG_ENABLE(imptcp,
+ [AS_HELP_STRING([--enable-imptcp],[plain tcp input module enabled @<:@default=no@:>@])],
+ [case "${enableval}" in
+ yes) enable_imptcp="yes" ;;
+ no) enable_imptcp="no" ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --enable-imptcp) ;;
+ esac],
+ [enable_imptcp=no]
+)
+AM_CONDITIONAL(ENABLE_IMPTCP, test x$enable_imptcp = xyes)
+
# settings for the omprog output module
AC_ARG_ENABLE(omprog,
@@ -877,6 +889,7 @@ AC_CONFIG_FILES([Makefile \
plugins/omuxsock/Makefile \
plugins/imfile/Makefile \
plugins/imsolaris/Makefile \
+ plugins/imptcp/Makefile \
plugins/imrelp/Makefile \
plugins/imdiag/Makefile \
plugins/omtesting/Makefile \
@@ -907,6 +920,7 @@ echo " Unlimited select() support enabled: $enable_unlimited_select"
echo
echo "---{ input plugins }---"
echo " Klog functionality enabled: $enable_klog ($os_type)"
+echo " plain tcp input module enabled: $enable_imptcp"
echo " imdiag enabled: $enable_imdiag"
echo " file input module enabled: $enable_imfile"
echo " Solaris input module enabled: $enable_imsolaris"