summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2009-06-02 07:44:07 +0200
committerRainer Gerhards <rgerhards@adiscon.com>2009-06-02 07:44:07 +0200
commit25daa04902f2754a487973c4de707869d66b84c1 (patch)
tree4ffb814a353fb16fc701a06bd3d034585763228d /configure.ac
parent02d8dc27f991d19f63c3fd9edb02610a97f003b3 (diff)
downloadrsyslog-25daa04902f2754a487973c4de707869d66b84c1.tar.gz
rsyslog-25daa04902f2754a487973c4de707869d66b84c1.tar.xz
rsyslog-25daa04902f2754a487973c4de707869d66b84c1.zip
added support for custom modules
... this provides some basic support to integrate extensions that are not direct parts of rsyslog to be built during its build process.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7150d211..9fc59f76 100644
--- a/configure.ac
+++ b/configure.ac
@@ -716,6 +716,20 @@ AC_ARG_ENABLE(omstdout,
)
AM_CONDITIONAL(ENABLE_OMSTDOUT, test x$enable_omstdout = xyes)
+# This provides a vehicle to integrate custom modules, that are not
+# part of rsyslog, into the build process. It is named cust1, so that
+# additional such modules can easily be added.
+AC_ARG_ENABLE(cust1,
+ [AS_HELP_STRING([--enable-cust1],[Compiles stdout module @<:@default=no@:>@])],
+ [case "${enableval}" in
+ yes) enable_cust1="yes" ;;
+ no) enable_cust1="no" ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --enable-cust1) ;;
+ esac],
+ [enable_cust1=no]
+)
+AM_CONDITIONAL(ENABLE_CUST1, test x$enable_cust1 = xyes)
+
# settings for the template input module; copy and modify this code
# if you intend to add your own module. Be sure to replace imtemplate
@@ -789,6 +803,7 @@ AC_CONFIG_FILES([Makefile \
plugins/ommail/Makefile \
plugins/omsnmp/Makefile \
plugins/omoracle/Makefile \
+ plugins/cust1/Makefile \
tests/Makefile])
AC_OUTPUT
@@ -802,6 +817,7 @@ echo " Regular expressions support enabled: $enable_regexp"
echo " Zlib compression support enabled: $enable_zlib"
echo " rsyslog runtime will be built: $enable_rsyslogrt"
echo " rsyslogd will be built: $enable_rsyslogd"
+echo " custom module 1 will be built: $enable_cust1"
echo
echo "---{ input plugins }---"
echo " Klog functionality enabled: $enable_klog ($os_type)"