summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2012-08-27 17:10:25 +0200
committerRainer Gerhards <rgerhards@adiscon.com>2012-08-27 17:10:25 +0200
commit2514bccdccaebe128055ffa0dc5132b4f4c48635 (patch)
treef423cd434483b74da6c524194be098e9d6c12eef /configure.ac
parenta74898dc827ed4a8f9587196716746031b1e5169 (diff)
parentec48c41e27ec15618f57b54209eaafe025e29010 (diff)
downloadrsyslog-2514bccdccaebe128055ffa0dc5132b4f4c48635.tar.gz
rsyslog-2514bccdccaebe128055ffa0dc5132b4f4c48635.tar.xz
rsyslog-2514bccdccaebe128055ffa0dc5132b4f4c48635.zip
Merge branch 'master-uuid'
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 80c086f4..78315a80 100644
--- a/configure.ac
+++ b/configure.ac
@@ -674,6 +674,21 @@ AM_CONDITIONAL(ENABLE_OMLIBDBI, test x$enable_libdbi = xyes)
AC_SUBST(LIBDBI_CFLAGS)
AC_SUBST(LIBDBI_LIBS)
+# libuuid support
+AC_CHECK_HEADERS(
+ [uuid/uuid.h],,
+ [AC_MSG_FAILURE([libuuid is missing])]
+)
+AC_CHECK_LIB(
+ [uuid],
+ [uuid_generate],
+ [LIBUUID_CFLAGS=""
+ LIBUUID_LIBS="-luuid"
+ ],
+ [AC_MSG_FAILURE([libuuid library is missing])]
+)
+AC_SUBST(LIBUUID_CFLAGS)
+AC_SUBST(LIBUUID_LIBS)
# SNMP support
AC_ARG_ENABLE(snmp,