summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2007-07-11 12:17:31 +0000
committerRainer Gerhards <rgerhards@adiscon.com>2007-07-11 12:17:31 +0000
commit1c133d93514914c2592d94d385d3b71f7667e5eb (patch)
tree8a3a84fe992c3cabb9d0cff8cc05dc7130a53faa /configure.ac
parent15852274b525f82f9361cbcb4f67c01a7b0af935 (diff)
downloadrsyslog-1c133d93514914c2592d94d385d3b71f7667e5eb.tar.gz
rsyslog-1c133d93514914c2592d94d385d3b71f7667e5eb.tar.xz
rsyslog-1c133d93514914c2592d94d385d3b71f7667e5eb.zip
remove file, its autotools output file and does not belong in CVS
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 16 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 49943f31..881776c5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -42,10 +42,6 @@ AC_FUNC_WAIT3
AC_CHECK_FUNCS([setsid alarm gethostbyname gethostname gettimeofday memset regcomp select socket strcasecmp strchr strerror strndup strrchr strstr strtol strtoul uname])
-# Ugly stuff
-AC_DEFINE(SYSLOG_INET, 1, [Why there is this macro])
-
-
# Large file support
AC_ARG_ENABLE(largefile,
[AC_HELP_STRING([--enable-largefile],[Enable large file support @<:@default=yes@:>@])],
@@ -148,6 +144,21 @@ if test "$enable_klogd" = "yes"; then
AC_DEFINE(FEATURE_KLOGD, 1, [klogd functionality is integrated.])
fi
+# inet
+AC_ARG_ENABLE(inet,
+ [AC_HELP_STRING([--enable-inet],[Enable networking support @<:@default=yes@:>@])],
+ [case "${enableval}" in
+ yes) enable_inet="yes" ;;
+ no) enable_inet="no" ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --enable-inet) ;;
+ esac],
+ [enable_inet="yes"]
+)
+if test "$enable_inet" = "yes"; then
+ AC_DEFINE(SYSLOG_INET, 1, [network support is integrated.])
+fi
+
+
# debug
AC_ARG_ENABLE(debug,
[AC_HELP_STRING([--enable-debug],[Enable debug mode @<:@default=no@:>@])],
@@ -174,5 +185,6 @@ echo "Regular expressions support enabled: $enable_regexp"
echo "Zlib compression support enabled: $enable_zlib"
echo "MySql support enabled: $enable_mysql"
echo "Large file support enabled: $enable_largefile"
+echo "Networking support enabled: $enable_inet"
echo "Debug mode enabled: $enable_debug"