summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2008-02-14 17:47:47 +0000
committerRainer Gerhards <rgerhards@adiscon.com>2008-02-14 17:47:47 +0000
commit15904a35388aafcda76ed44caab9222619901dd4 (patch)
tree127345ed0395a993eee6b8993a31ef2f81175b5a /configure.ac
parent4e7434ef98cc77f9cb49f628c1250195312590dd (diff)
downloadrsyslog-15904a35388aafcda76ed44caab9222619901dd4.tar.gz
rsyslog-15904a35388aafcda76ed44caab9222619901dd4.tar.xz
rsyslog-15904a35388aafcda76ed44caab9222619901dd4.zip
created an initial version of omlibdbi (does not yet work)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac33
1 files changed, 14 insertions, 19 deletions
diff --git a/configure.ac b/configure.ac
index 49b020af..6bae1c98 100644
--- a/configure.ac
+++ b/configure.ac
@@ -389,25 +389,20 @@ AC_ARG_ENABLE(libdbi,
esac],
[enable_libdbi=no]
)
-#if test "x$enable_libdbi" = "xyes"; then
-# AC_CHECK_PROG(
-# [HAVE_PGSQL_CONFIG],
-# [pg_config],
-# [yes],,,
-# )
-# if test "x${HAVE_PGSQL_CONFIG}" != "xyes"; then
-# AC_MSG_FAILURE([pg_config not found in PATH])
-# fi
-# AC_CHECK_LIB(
-# [pq],
-# [PQconnectdb],
-# [pgsql_cflags="-I`pg_config --includedir`"
-# pgsql_libs="`pg_config --libdir` -lpq"
-# ],
-# [AC_MSG_FAILURE([PgSQL library is missing])],
-# [-L`pg_config --libdir`]
-# )
-#fi
+if test "x$enable_libdbi" = "xyes"; then
+ AC_CHECK_HEADERS(
+ [dbi/dbi.h],,
+ [AC_MSG_FAILURE([libdbi is missing])]
+ )
+ AC_CHECK_LIB(
+ [dbi],
+ [dbi_initialize],
+ [libdbi_cflags=""
+ libdbi_libs="-ldbi"
+ ],
+ [AC_MSG_FAILURE([libdbi library is missing])]
+ )
+fi
AM_CONDITIONAL(ENABLE_OMLIBDBI, test x$enable_libdbi = xyes)
AC_SUBST(libdbi_cflags)
AC_SUBST(libdbi_libs)