summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2007-12-05 11:33:46 +0000
committerRainer Gerhards <rgerhards@adiscon.com>2007-12-05 11:33:46 +0000
commit0991cf95d9114f8d5e18e3d005f997055d1a6387 (patch)
tree861869e1e4217e592fcc72364fd014b8213557bc /configure.ac
parent05fd4c0e657f409ea50a032686758049731f75c8 (diff)
downloadrsyslog-0991cf95d9114f8d5e18e3d005f997055d1a6387.tar.gz
rsyslog-0991cf95d9114f8d5e18e3d005f997055d1a6387.tar.xz
rsyslog-0991cf95d9114f8d5e18e3d005f997055d1a6387.zip
applied patch from Michael Biebl to fix compilation problem on NetBSD (it
is missing the -ldl lib, even though it provides dlopen())
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index a0ef204e..bafa07aa 100644
--- a/configure.ac
+++ b/configure.ac
@@ -30,8 +30,10 @@ case "${host}" in
esac
# Checks for libraries.
-AC_CHECK_LIB(rt,clock_gettime,[dl_libs="-ldl" AC_SUBST(dl_libs)],,)
-AC_CHECK_LIB(dl,dlopen,[rt_libs="-lrt" AC_SUBST(rt_libs)],,)
+save_LIBS=$LIBS
+AC_SEARCH_LIBS(clock_gettime, rt, [dl_libs="-ldl" AC_SUBST(dl_libs)])
+AC_SEARCH_LIBS(dlopen, dl, [rt_libs="-lrt" AC_SUBST(rt_libs)])
+LIBS=$save_LIBS
# Checks for header files.
AC_HEADER_RESOLV