summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2009-11-17 10:38:46 +0100
committerRainer Gerhards <rgerhards@adiscon.com>2009-11-17 10:38:46 +0100
commit0957820a1076d7fcf182ba60c12e5946c193545f (patch)
tree2339489d05441895d1b221cab59fae36816c33eb /configure.ac
parentc9841fbd368e58674cc166e6186b2a29f9895211 (diff)
parent9e28d47aaa506709a9e80e318527ceb4443cbffe (diff)
downloadrsyslog-0957820a1076d7fcf182ba60c12e5946c193545f.tar.gz
rsyslog-0957820a1076d7fcf182ba60c12e5946c193545f.tar.xz
rsyslog-0957820a1076d7fcf182ba60c12e5946c193545f.zip
Merge branch 'v4-devel'
Conflicts: doc/rsyslog_conf_modules.html gss-misc.c plugins/imgssapi/imgssapi.c plugins/imudp/imudp.c plugins/imuxsock/imuxsock.c runtime/glbl.c runtime/glbl.h runtime/net.c
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2ce99b94..4061b620 100644
--- a/configure.ac
+++ b/configure.ac
@@ -346,6 +346,21 @@ AC_ARG_ENABLE([fsstnd],
])
+# support for unlimited select() syscall
+AC_ARG_ENABLE(unlimited_select,
+ [AS_HELP_STRING([--enable-unlimited-select],[Enable unlimited select() syscall @<:@default=no@:>@])],
+ [case "${enableval}" in
+ yes) enable_unlimited_select="yes" ;;
+ no) enable_unlimited_select="no" ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --enable-unlimited-select) ;;
+ esac],
+ [enable_unlimited_select="no"]
+)
+if test "$enable_unlimited_select" = "yes"; then
+ AC_DEFINE(USE_UNLIMITED_SELECT, 1, [If defined, the select() syscall won't be limited to a particular number of file descriptors.])
+fi
+
+
# debug
AC_ARG_ENABLE(debug,
[AS_HELP_STRING([--enable-debug],[Enable debug mode @<:@default=no@:>@])],
@@ -940,6 +955,7 @@ echo " rsyslog runtime will be built: $enable_rsyslogrt"
echo " rsyslogd will be built: $enable_rsyslogd"
echo " GUI components will be built: $enable_gui"
echo " custom module 1 will be built: $enable_cust1"
+echo " Unlimited select() support enabled: $enable_unlimited_select"
echo
echo "---{ input plugins }---"
echo " Klog functionality enabled: $enable_klog ($os_type)"