summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2008-02-18 09:59:33 +0000
committerRainer Gerhards <rgerhards@adiscon.com>2008-02-18 09:59:33 +0000
commit069c1d2b6f33da29548547d05338c08d0304f24d (patch)
tree5e98e11ad23ef97b9b289b45722a392bcb2a503e /configure.ac
parent12274407143957481c1dbcc94390418d932b582d (diff)
downloadrsyslog-069c1d2b6f33da29548547d05338c08d0304f24d.tar.gz
rsyslog-069c1d2b6f33da29548547d05338c08d0304f24d.tar.xz
rsyslog-069c1d2b6f33da29548547d05338c08d0304f24d.zip
applied patch from Michael Biebl to auto-detect new libdbi version
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4e77e933..59bd1195 100644
--- a/configure.ac
+++ b/configure.ac
@@ -402,6 +402,11 @@ if test "x$enable_libdbi" = "xyes"; then
],
[AC_MSG_FAILURE([libdbi library is missing])]
)
+ AC_CHECK_LIB(
+ [dbi],
+ [dbi_initialize_r],
+ [AC_DEFINE([HAVE_DBI_R], [1], [Define to 1 if libdbi supports the new plugin-safe interface])]
+ )
fi
AM_CONDITIONAL(ENABLE_OMLIBDBI, test x$enable_libdbi = xyes)
AC_SUBST(libdbi_cflags)