summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2007-10-08 10:45:05 +0000
committerRainer Gerhards <rgerhards@adiscon.com>2007-10-08 10:45:05 +0000
commitd5feea59255ac45328de6ec8e9478fc1b12b4145 (patch)
tree7297d9cfca9a06e9c4699fb6e55886ea33b31d64 /Makefile.am
parent3855edc9281f798f29f5f445dbdd08b147988170 (diff)
downloadrsyslog-d5feea59255ac45328de6ec8e9478fc1b12b4145.tar.gz
rsyslog-d5feea59255ac45328de6ec8e9478fc1b12b4145.tar.xz
rsyslog-d5feea59255ac45328de6ec8e9478fc1b12b4145.zip
changed the threading to include one extra thread that runs the mainloop.
This was done to work around a problem with malloc/free. Note that we are still running on two threads - the startup thread just waits for the new one to finish. For a description of the problem I try to work-around, please see: http://rgerhards.blogspot.com/2007/10/could-i-really-reproduce-bug.html Note that this is an experimental change, which will only stay if it proves to fix the segfault issue we are dealing with.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 642e7e17..4b33ce5b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -7,8 +7,8 @@ rfc3195d_SOURCES=rfc3195d.c rsyslog.h
man_MANS = rfc3195d.8 rklogd.8 rsyslogd.8 rsyslog.conf.5
rsyslogd_SOURCES=syslogd.c pidfile.c template.c outchannel.c stringbuf.c srUtils.c parse.c syslogd-types.h template.h outchannel.h syslogd.h stringbuf.h parse.h srUtils.h liblogging-stub.h net.c net.h msg.c msg.h omshell.c omshell.h omusrmsg.c omusrmsg.h omfwd.c omfwd.h tcpsyslog.c tcpsyslog.h omfile.h omfile.c omdiscard.c omdiscard.h modules.c modules.h module-template.h objomsr.c objomsr.h cfsysline.c cfsysline.h linkedlist.c linkedlist.h iminternal.c iminternal.h action.c action.h
-rsyslogd_CPPFLAGS=-D_PATH_MODDIR=\"$(pkglibdir)/\"
-rsyslogd_LDADD=$(zlib_libs) $(pthreads_libs) -ldl
+rsyslogd_CPPFLAGS=-O1 -fmudflapth -D_PATH_MODDIR=\"$(pkglibdir)/\"
+rsyslogd_LDADD=$(zlib_libs) $(pthreads_libs) -ldl -lmudflapth
rsyslogd_LDFLAGS=-export-dynamic
EXTRA_DIST = doc/bugs.html doc/features.html doc/generic_design.html doc/history.html doc/how2help.html doc/install.html doc/ipv6.html doc/manual.html doc/property_replacer.html doc/rsyslog_conf.html doc/rsyslog_mysql.html doc/rsyslog_packages.html doc/rsyslog_php_syslog_ng.html doc/rsyslog_recording_pri.html doc/rsyslog_stunnel.html doc/status.html doc/syslog-protocol.html doc/version_naming.html doc/contributors.html redhat/rsyslog.conf redhat/rsyslog.init redhat/rsyslog.log redhat/rsyslog.sysconfig freebsd/rsyslogd slackware/rc.rsyslogd rfc3195d.8 rklogd.8 rsyslogd.8 rsyslog.conf.5 contrib/README doc/rsconf1_actionexeconlyifpreviousissuspended.html doc/rsconf1_actionresumeinterval.html doc/rsconf1_allowedsender.html doc/rsconf1_controlcharacterescapeprefix.html doc/rsconf1_debugprintcfsyslinehandlerlist.html doc/rsconf1_debugprintmodulelist.html doc/rsconf1_debugprinttemplatelist.html doc/rsconf1_dircreatemode.html doc/rsconf1_dirgroup.html doc/rsconf1_dirowner.html doc/rsconf1_dropmsgswithmaliciousdnsptrrecords.html doc/rsconf1_droptrailinglfonreception.html doc/rsconf1_dynafilecachesize.html doc/rsconf1_escapecontrolcharactersonreceive.html doc/rsconf1_failonchownfailure.html doc/rsconf1_filecreatemode.html doc/rsconf1_filegroup.html doc/rsconf1_fileowner.html doc/rsconf1_includeconfig.html doc/rsconf1_mainmsgqueuesize.html doc/rsconf1_modload.html doc/rsconf1_repeatedmsgreduction.html doc/rsconf1_resetconfigvariables.html doc/rsconf1_umask.html plugins/ommysql/ommysql.tar.gz