summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorRainer Gerhards <rgerhards@adiscon.com>2008-03-05 10:30:06 +0000
committerRainer Gerhards <rgerhards@adiscon.com>2008-03-05 10:30:06 +0000
commit545346e697fe930b8b7b9bd0ede47890b26a4832 (patch)
treed0cfea13a087e00238107347dd3ffb7b9e20f31e /Makefile.am
parent89fac41d646711e40a0549dfc197cdd7a7d5f18c (diff)
downloadrsyslog-545346e697fe930b8b7b9bd0ede47890b26a4832.tar.gz
rsyslog-545346e697fe930b8b7b9bd0ede47890b26a4832.tar.xz
rsyslog-545346e697fe930b8b7b9bd0ede47890b26a4832.zip
- changed modules.c calling conventions to be interface-based
- moved module loader from conf.c to module.c, where it belongs - made the necessary plumbing to auto-load library modules - upgraded debug system to include iRet in function exit message - changed module interface so that instances need only to be supported by output plugins (if we actually need them for input plugins, we can always add it again...) - milestone: first implementation of library modules (but do not get unloaded on exit/hup so far)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 12 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 83503390..ce9f80da 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3,10 +3,6 @@ sbin_PROGRAMS = rfc3195d rsyslogd
rfc3195d_SOURCES = rfc3195d.c rsyslog.h
rsyslogd_SOURCES = \
- tcps_sess.c \
- tcps_sess.h \
- tcpsrv.c \
- tcpsrv.h \
syslogd.c \
syslogd.h \
sysvar.c \
@@ -101,6 +97,18 @@ libgssapi_misc_la_SOURCES = gss-misc.c gss-misc.h
libgssapi_misc_la_LIBADD = $(gss_libs)
endif
+# now come the library plugins
+pkglib_LTLIBRARIES = tcpsrv.la
+
+tcpsrv_la_SOURCES = \
+ tcps_sess.c \
+ tcps_sess.h \
+ tcpsrv.c \
+ tcpsrv.h
+tcpsrv_la_CPPFLAGS = $(pthreads_cflags) $(mudflap_cflags)
+tcpsrv_la_LDFLAGS = $(mudflap_libs) -module -avoid-version
+tcpsrv_la_LIBADD =
+
man_MANS = rfc3195d.8 rsyslogd.8 rsyslog.conf.5
EXTRA_DIST = \