summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index f1a5885..0e6c301 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -35,7 +35,8 @@ AM_CPPFLAGS = -I $(top_srcdir)/include $(GLIB_CFLAGS) $(NSS_CFLAGS) \
## Targets
lib_LTLIBRARIES = lib/libncrypto.la
pkginclude_HEADERS = include/ncrypto/ncrypto.h
-TESTS = tests/digests tests/rsa tests/symm_ciphers tests/symm_signatures
+TESTS = tests/digests tests/rsa tests/symm_ciphers tests/symm_keys \
+ tests/symm_signatures
## Rules
noinst_PROGRAMS = $(TESTS)
@@ -53,5 +54,8 @@ tests_rsa_LDFLAGS = -no-install
tests_symm_ciphers_LDADD = lib/libncrypto.la $(GLIB_LIBS)
tests_symm_ciphers_LDFLAGS = -no-install
+tests_symm_keys_LDADD = lib/libncrypto.la $(GLIB_LIBS)
+tests_symm_keys_LDFLAGS = -no-install
+
tests_symm_signatures_LDADD = lib/libncrypto.la $(GLIB_LIBS)
tests_symm_signatures_LDFLAGS = -no-install