summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am40
1 files changed, 40 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..e19052e
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,40 @@
+# Copyright 2010 Red Hat, Inc.
+#
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions are met:
+#
+# 1. Redistributions of source code must retain the above copyright notice,
+# this list of conditions and the following disclaimer.
+#
+# 2. Redistributions in binary form must reproduce the above copyright notice,
+# this list of conditions and the following disclaimer in the documentation
+# and/or other materials provided with the distribution.
+#
+# THIS SOFTWARE IS PROVIDED BY CONTRIBUTORS ``AS IS'' AND ANY EXPRESS OR
+# IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+#
+# Red Hat author: Miloslav Trmač <mitr@redhat.com>
+
+## Process this file with automake to produce Makefile.in
+
+## Settings
+versionedincludedir = $(includedir)/ncrypto-0/ncrypto
+
+ACLOCAL_AMFLAGS = -I m4
+AM_CPPFLAGS = -I $(top_srcdir)/include $(NSS_CFLAGS) $(GLIB_CFLAGS)
+
+## Targets
+lib_LTLIBRARIES = lib/libncrypto.la
+pkginclude_HEADERS = include/ncrypto/ncrypto.h
+
+## Rules
+lib_libncrypto_la_SOURCES = lib/ncrypto.c
+lib_libncrypto_la_LDFLAGS = -version-info 0:0:0 \ No newline at end of file