summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 0e6c301..7019a5f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -35,8 +35,8 @@ AM_CPPFLAGS = -I $(top_srcdir)/include $(GLIB_CFLAGS) $(NSS_CFLAGS) \
## Targets
lib_LTLIBRARIES = lib/libncrypto.la
pkginclude_HEADERS = include/ncrypto/ncrypto.h
-TESTS = tests/digests tests/rsa tests/symm_ciphers tests/symm_keys \
- tests/symm_signatures
+TESTS = tests/digests tests/private_keys tests/rsa \
+ tests/symm_ciphers tests/symm_keys tests/symm_signatures
## Rules
noinst_PROGRAMS = $(TESTS)
@@ -48,6 +48,9 @@ lib_libncrypto_la_LDFLAGS = -version-info 0:0:0 $(NSS_LIBS) $(OPENSSL_LIBS)
tests_digests_LDADD = lib/libncrypto.la $(GLIB_LIBS)
tests_digests_LDFLAGS = -no-install
+tests_private_keys_LDADD = lib/libncrypto.la $(GLIB_LIBS)
+tests_private_keys_LDFLAGS = -no-install
+
tests_rsa_LDADD = lib/libncrypto.la $(GLIB_LIBS)
tests_rsa_LDFLAGS = -no-install