summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMiloslav Trmač <mitr@redhat.com>2010-10-04 21:25:21 +0200
committerMiloslav Trmač <mitr@redhat.com>2010-10-04 21:25:21 +0200
commit566ee5e8a43f6f9c5705c9d154e89cf43759b77f (patch)
treeefd72b5c8422f192ebeb569036375469e5845ff5 /Makefile.am
parent91475817b3f08ebf76cee39271aa5a692c8930d5 (diff)
downloadncrypto-566ee5e8a43f6f9c5705c9d154e89cf43759b77f.tar.gz
ncrypto-566ee5e8a43f6f9c5705c9d154e89cf43759b77f.tar.xz
ncrypto-566ee5e8a43f6f9c5705c9d154e89cf43759b77f.zip
Add basic digest support
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 10 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index e19052e..2d4a0ab 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -29,12 +29,19 @@
versionedincludedir = $(includedir)/ncrypto-0/ncrypto
ACLOCAL_AMFLAGS = -I m4
-AM_CPPFLAGS = -I $(top_srcdir)/include $(NSS_CFLAGS) $(GLIB_CFLAGS)
+AM_CPPFLAGS = -I $(top_srcdir)/include $(GLIB_CFLAGS) $(NSS_CFLAGS) \
+ $(OPENSSL_CFLAGS)
## Targets
lib_LTLIBRARIES = lib/libncrypto.la
pkginclude_HEADERS = include/ncrypto/ncrypto.h
+TESTS = tests/digests
## Rules
-lib_libncrypto_la_SOURCES = lib/ncrypto.c
-lib_libncrypto_la_LDFLAGS = -version-info 0:0:0 \ No newline at end of file
+noinst_PROGRAMS = $(TESTS)
+
+lib_libncrypto_la_SOURCES = lib/ncrypto.c lib/ncrypto_local.c
+lib_libncrypto_la_LDFLAGS = -version-info 0:0:0 $(OPENSSL_LIBS)
+
+tests_digests_LDADD = lib/libncrypto.la $(GLIB_LIBS)
+tests_digests_LDFLAGS = -no-install