summaryrefslogtreecommitdiffstats
path: root/t/Makefile.am
diff options
context:
space:
mode:
authorGergely Nagy <algernon@balabit.hu>2012-08-10 14:07:29 +0200
committerGergely Nagy <algernon@balabit.hu>2012-08-10 16:53:06 +0200
commit8af1d67bd3e8a1766cb9984b3771162cc4c19669 (patch)
treed77ebb9f38a81c98a40bf41cbdc2548f987fd645 /t/Makefile.am
parent7d21f9316f32168acefcfe40b5b4b91c8378369c (diff)
downloadlibumberlog-8af1d67bd3e8a1766cb9984b3771162cc4c19669.tar.gz
libumberlog-8af1d67bd3e8a1766cb9984b3771162cc4c19669.tar.xz
libumberlog-8af1d67bd3e8a1766cb9984b3771162cc4c19669.zip
Split the library into a linkable and an LD_PRELOAD-able part
In order to satisfy the desire of using libumberlog, specifically ul_format(), without having to worry about syslog() & friends being overridden, split the library into two parts: A linkable library, which provides the new API, but does not override the legacy syslog() functions; and a new, LD_PRELOAD-able part, which does override the old ones. Signed-off-by: Gergely Nagy <algernon@balabit.hu>
Diffstat (limited to 't/Makefile.am')
-rw-r--r--t/Makefile.am17
1 files changed, 12 insertions, 5 deletions
diff --git a/t/Makefile.am b/t/Makefile.am
index d6a0118..3f3a973 100644
--- a/t/Makefile.am
+++ b/t/Makefile.am
@@ -1,8 +1,15 @@
if ENABLE_TESTS
-TESTS = test_umberlog test_perf
-check_PROGRAMS = ${TESTS}
+TESTS = test_umberlog_preload test_umberlog test_perf
+check_PROGRAMS = ${TESTS}
-AM_CFLAGS = -I$(top_srcdir)/lib @JSON_CFLAGS@ @CHECK_CFLAGS@
-AM_LDFLAGS = -no-install
-LDADD = $(top_builddir)/lib/libumberlog.la @JSON_LIBS@ @CHECK_LIBS@
+AM_CFLAGS = -I$(top_srcdir)/lib @JSON_CFLAGS@ @CHECK_CFLAGS@
+AM_LDFLAGS = -no-install
+LDADD = @JSON_LIBS@ @CHECK_LIBS@
+
+check_LTLIBRARIES = libultest.la
+libultest_la_SOURCES = test-common.c test-common.h
+
+test_umberlog_preload_LDADD = ${LDADD} $(top_builddir)/lib/libumberlog_preload.la libultest.la
+test_umberlog_LDADD = ${LDADD} $(top_builddir)/lib/libumberlog.la libultest.la
+test_perf_LDADD = ${LDADD} $(top_builddir)/lib/libumberlog.la libultest.la
endif